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Preface 
This manual describes the main functionality delivered by the CATIA Teamcenter 

Interface (CMI) and includes the creation, storage, modif ication and management of  

CATIA models and assembly structures in the Teamcenter Enterprise PDM system. 

 

About this Manual 

This manual is intended for end users of  the CATIA Teamcenter Interface. It assumes that 
the reader is familiar with the CATIA application and with Teamcenter Enterprise Object 

Management Framework (OMF) as described in the Object Management Framework 

User’s Manual.  

 

Related Documents 

The following manuals contain information about installation, usage and customization of  

the CATIA Teamcenter Interface:  
 
Manual Title Version 

CATIA Teamcenter Interface Installation & Administration Guide 10.17 
CATIA Teamcenter Interface User Manual 10.17 
CATIA Teamcenter Interface Customizing Guide 10.17 

 

Organization 

This manual contains the following chapters, some are specif ic to a particular version of  

CATIA, either V4 or V5, or are valid for both: 

Chapter 1 provides basic information about the CATIA Teamcenter Interface and 

describes some features of  this application interface.  

Chapter 2 describes how to start CATIA within the Teamcenter environment and also how 
to enable the CATEDM Module in the CATIA Function Palette. Assumed is that the 
CATEDM module will be referenced under the function name ‘METAPHSE’ within the 

CATIA working session (default setting during the installation). 

Chapter 3 introduces the CATIA Workbench and lists its functions. The goal of  this 
chapter is to make the user familiar with this component of  CMI. The CATIA Workbench 

functions will be explained in depth in subsequent chapters. 

Chapter 4 describes how to create and search for CATIA models.  

Chapter 5 describes how to load documents stored in Teamcenter into CATIA, how to 

update a model, how to save it under another name and how to create plot f iles. 

Chapter 6 explains the concepts underlying the work with structures and describes how to 
create assemblies and components, how to search for parts, how to load parts into CATIA 

and how to modify the assembly structure and assembly positions.  

Chapter 7 delves into the menu items of  the METAPHSE function in CATIA and describes 

how to modify the structure and the position of  sub-assemblies. 

Chapter 8 explains how to work with CATIA V5  

Glossary contains the CATIA Teamcenter Interface terminology. 
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Conventions Used in this Manual 

This font  Is used for document titles and emphasis. 

 

Item 1 > Item 2 Is used to identify a menu path to reach a specif ic function 

 

METAPHSE Is used to identify a CATIA V4 function. 

 

 

This icon is used to identify tips and attention advices. 

 

 
This icon is used to identify vault related tips. 

 

 
This icon is used to identify Teamcenter Enterprise related sections and actions. 

 

 

This icon is used to identify CATIA related sections and actions. 

 

 

This icon is used to identify CATIA V5 related sections and actions.  

 

 
This icon is used to identify actions that need conf irmation.  

 

 

Your Comments are Welcome 

Please feel f ree to tell us your opinion; we are always interested in improving our 

publications. Mail your comments to: 

T-Systems International GmbH 
Fasanenweg 5 
70771 Leinfelden-Echterdingen 

Germany 
 
mail: cmi_support@t-systems.com 

 

mailto:cmi_support@t-systems.com
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CHAPTER 1 

Overview  
This chapter provides basic information about the CATIA Teamcenter Interface and lists 

some features of  this application interface. 

 

Introducing CMI (CATIA Teamcenter Interface) 

The CATIA Teamcenter Interface (CMI) was developed by T-Systems as a high-end 

integration between the CAD system CATIA V4 and V5 and the PDM system Teamcenter 
Enterprise. With this interface it is possible to manage CATIA V4 and V5 models and 

assemblies in the Teamcenter Enterprise  and CATIA V4 and V5.  

CATIA V5 uses assemblies similar to Teamcenter Enterprise. CMI makes a bidirectional 
mapping between the Teamcenter Enterprise structure and the CATIA V5 structure. So 

users have the full functionality of  Teamcenter Enterprise and CATIA V5. 

 

CMI joins the advantages of CAD with PDM 

The CATIA Teamcenter Interface combines the CAD Excellency of  CATIA with the power 

of  the PDM system Teamcenter Enterprise. It provides the user with a more sophisticated 
way of  working with CATIA by allowing the management of  product structures and multiple 

level assembly structures within the PDM system. 

The CATIA Teamcenter Interface (CMI) permits: 

Integration of  CATIA data in workf low (e.g. release control);  

Management of  CATIA data in vaults, without knowledge about the underlying f ile system;  

Updating concurrent engineering processes by dif ferent users; 

Attachment of  plot f iles to their corresponding CATIA models; 

Distribution of  CATIA data in a network; 

Simultaneous management of  CATIA data and structures;  

Construction of  part structures within Teamcenter Enterprise; 

Individual Parts to contain more than one physical CATIA model; 

Modif ication of  the position of  the structures; 

Search for CATIA data by dif ferent attributes; 

Automatic loading of  attributes stored in Teamcenter Enterprise to f ill the title blocks of  

CATIA drawings. 
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CMI Architecture 

The following f igure explains the architectural basics of  the CATIA Teamcenter Interface 

(CMI). 

 

 

Figure 1: CATIA Teamcenter Interface architecture 

The user can expand an assembly within the CATIA Workbench and send this assembly 
to CATIA V4 or CATIA V5. Af ter changing geometries and / or positions in CATIA the user 

can update the assembly in Teamcenter Enterprise.  



 

CMI User Manual   3 

CHAPTER 2 

Getting Started 
This chapter describes how to start CATIA within the Teamcenter Enterprise environment 

and also how to enable the CMI functionality within CATIA V4 and CATIA V5. 

 

Assumptions 

Some assumptions, for a better understanding of  the descriptions and examples:  

 

The CATIA V4 functionality is installed with the menu item name ‘CMI’ in CATIA.  

CATIA can be called both directly f rom the user’s desktop environment and f rom a 

UNIX shell via the command ‘catstart.sh’. 

 

 CATIA V5 should display the CMI toolbar:  

UNIX: 

Start CATIA V5 with the command cmicatstart.sh   

Windows: 
Make sure you have set up the right environment (refer to Installation and 
Administration Guide). Launch CATIA V5 with the command: 

CNEXT.exe  -env CatiaCMIEnv -direnv "C:\<path to the CMIEnv>"  

 

Starting Applications 

Before working with CMI it is necessary to start the OMF, the classic Teamcenter 
Enterprise user interface, and the Motif  CATIA User Interface or the Windows version of  

CATIA. 

For information on starting OMF see the Object Management Framework User’s Manual – 

chapter 1 (Before You Begin), section Starting OMF provided b y UGS PLM Solutions. 

For information on starting the CATIA User Interface see the CATIA Solutions User’s 

Guide. 

 

 

If  the CATIA Launching Tool  is installed, it is possible to start CATIA f rom the OMF 

Browser in Teamcenter Enterprise by double-clicking the icon: 

 

To install the CATIA Launching Tool you should take a look at the CATIA 

Teamcenter Installation Manual – chapter 2 (Installing CATIA Launching Tool). 
 

 
If  CATIA is not started out of  the OMF, it makes no dif ference if  Teamcenter 

Enterprise or CATIA is started f irst. 
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Enabling the CMI toolbar in CATIA V5  

 

 

In CATIA V5, select the menu View>Toolbars>CMI , View>Toolbars>CMIGeometry 
Tools, View>Toolbars>Advanced Tools 

 

 
If  the CMI toolbar is not in the list of  toolbars, a problem with the installation may 

have occurred. In this case, contact the administrator. Information about this kind of  

problem can be found in the Installation Manual. 

 

 

Enabling CMI in the CATIA V4 Function Palette 

 

 

In CATIA, select the KEY permanent function or the FILE > KEYBOARD item. 

Select METAPHSE in the list of  functions on the right. 

Select a function key on the lef t (select a function that will probably not be used). 
 

The METAPHSE function will be swapped with the function selected in step 3.  

 

 
It is possible to store the palette so that it is not necessary to enable the 
METAPHSE function every time CATIA is restarted. For information about storing 

palettes see the Motif CATIA Solutions User’s Guide – chapter 3  (Presenting the 

Motif CATIA User Interface), section Storing Palettes: STORE Item. 

 

 
If  the METAPHSE option is not in the list of  functions on the right, a problem with 
the installation may have occurred. In this case, contact the administrator. 

Information about this kind of  problem can be found in the Installation Manual. 
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CHAPTER 3 

The CATIA Workbench 
This chapter introduces the CATIA Workbench with a general explanation and then by 
listing its functions. The goal of  this chapter is to make the user familiar with this 

component. The CATIA Workbench functions will be explained in subsequent chapters. 

 

What is the CATIA Workbench? 

The CATIA Workbench is a standard Teamcenter Enterprise structure browser, used to 
graphically prepare an assembly structure for sending to CATIA and to provide several 
manipulation facilities for the CMI commands found in CATIA. The entire data interchange 

between Teamcenter Enterprise and CATIA is achieved via the CATIA Workbench. 

First of  all you should register or create some CATIA model objects in Teamcenter 
Enterprise. CMI def ines some new classes in Teamcenter that can be used to manage 

CATIA models plus plot f iles generated f rom them, and also new classes to manage the 
CATPart, CATProduct and CATDrawing f iles of  CATIA V5. The management of  CATIA 

models is described in Chapter 5,  CATIA V5 f iles in Chapter 8 

 

 

 

The CATIA Workbench in Teamcenter Enterprise has to be started before yo u can 

call the functions of  CMI (CATIA Teamcenter Interface). 

 

To open the CATIA Workbench either select the Teamcenter Enterprise function: 

 

 
Window  > CATIA Workbench 

 

Or select a CATIA model in Teamcenter Enterprise and double click on it  

A window as the one seen below will appear: 
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Figure 2: CATIA Workbench window. 

The initialization of  the communication between CATIA and Teamcenter Enterprise was 

successful if  the title of  the CATIA Workbench has the following format: 

 

 

Figure 3: CATIA Workbench Title bar description 

If  the title bar of  the CATIA Workbench doesn’t show your workstation host name and a 

port number, please consult your administrator. 

 

The CATIA Workbench Menu 

Below the CATIA Workbench menu items will be described. 

 

Figure 4: CATIA Workbench menu items. 

 
 

Work with V4/V5  Your host name  Port number 
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Menu item File 

 

Figure 5: CATIA Workbench menu ‘File’. 

The menu item File > Save Session will save the contents of  the CATIA Workbench in the 
database. To restore the contents of  the CATIA Workbench use the standard Teamcenter 

Query for ‘Saved CATIA Session‘, please refer to chapter 5. 

The menu item File > Import 4D-Nav File will load a scene-f ile that had been written and 
modif ied by the 4D-Navigator. All models below parts that are ‘visible’ in the 4D-Nav will 

become marked in the CATIA-Workbench.  

The other points in the menu item File contain standard Teamcenter Enterprise File items. 

For more information about the entries, please refer to: 

 

 
Help > Menus 

Menu item Action 

 

Figure 6: CATIA Workbench menu ‘Action’. 
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The Action menu allows the sending of  the CATIA Workbench contents to CATIA V4 and 

CATIA V5. 

The menu item Action > To CATIA  will send the contents of  the CATIA Workbench to the 

CATIA session and the CATIA session window will appear.  

This menu item is only selectable, if  items are present in the CATIA Workbench. 

The menu item Action > Add To CATIA  will add additional contents or remove 

deexpanded contents of  the CATIA Workbench to the CATIA session and the CATIA 
session window will appear. Only the newly added items will be loaded into the existing 
Catia session. 

This menu item is only selectable, if  items are present in the CATIA Workbench. 

If  working with Catia V5, Add To Catia will add the Workbench contents to a single 

product Window, below a synthetic Product tagged “CMI Workbench”.  

The menu item Action > To 4D-Navigator will send the contents of  the CATIA Workbench 
to the 4D-Navigator that will appear. If  there is still a 4D-Navigator running, the content of  

the CATIA-Workbench is added to the former content of  the 4D-Navigator. 

With the “To viewer” command the content of  the CMI Workbench can be sent to a 
specif ic viewer to obtain a quick preview out of  TC Enterprise. This functionality is also 

available without a CATIA V5 installation! 

The menu item Action > Cancel To CATIA cancels the communication between CATIA 

Workbench and CATIA session and the CATIA session window will appear. 

The menu item Action > Clear Workbench will erase all data in the Workbench. 

The menu item Action > Mark Selected Items will mark all items that are currently 

selected. 

The menu item Action > Browse Selected Items will generate a Browser with all selected 

persistent objects. (The Workbench contains only dynamic Representation-objects of  
persistent Teamcenter-objects, to work on the origin-objects you should apply this 

command) 

The menu item Action > Marked Items > De-expand Marked Items removes the marked 

parts f rom the CATIA Workbench including all subassemblies. 

The menu item Action > Marked Items > Unmark All will unmark all items in the 

workbench.  

The menu item Action > Marked Items > Marked Items To CATIA will send all marked 

items to CATIA. 

The menu item Action > Marked Items > Add Marked Items To CATIA V4 will send all 

marked items to CATIA V4. 

The menu item Action > Marked Items > Highlight Marked Items will highlight all marked 

items in CATIA. 

The menu item Action > Marked Items > Marked to 4D-Navigator will send all marked 

items to the 4D-Navigator. 

The menu item Action > Marked Items > Marked to Viewer will send all marked items to a 

specif ic Viewer. 

The menu item Action > Marked Items > Browse Marked Items will generate a Browser 

with all marked persistent objects 

The menu item Action > Create DMU File creates a CMI-DMU-File for the clicked Part in 
the DMU-Vault Location. Every Revision of  the Part has its own DMU-File stored in the 
Vault Location. If  the DMU-File already exists in the Vault, the user has to conf irm the 

overwrite. The Root-Part is expanded for all Catia-Models. For each Catia-Model an entry 
is stored in the f ile with the absolute postion and the assembly path f rom the Root-Part to 

the Model.  
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Menu item Info 

 

Figure 7: CATIA Workbench menu ‘Info’. 

The menu item Info > Get Item Info displays extended information about an item that the 

user has selected in the CATIA Workbench. 

The menu item Info > Get WB Content Info displays the number of  CATIA parts and 

models within the CATIA Workbench. Also the size of  the contained CATIA models will be 

displayed. This information dialog helps to estimate the size of  the CATIA-Session. 

Menu item Query 

 

Figure 8: CATIA Workbench menu ‘Query’. 

The menu item Query searches for documents and parts (standard Teamcenter 

Enterprise). 

The menu item Query > CATIA-Item searches for CATIA-Items within the Workbench. All 
items matching the search criteria are marked (for more information about marked items, 

please refer to ‘Working with marked Parts‘). 

The menu item Query > CATIA-Model searches for CATIA-Models within the Workbench. 

All models matching the search criteria are marked. 
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Menu item Query  >  DMU 

 

Figure 9: CATIA Workbench menu ‘Query DMU’. 

 

 
You should use this functionality only for f rozen data. Therefore use the 

conf iguration context to query only for f rozen data. 

The menu item Query > DMU > Show Neighbours is active when at least one Catia-Model 

is selected (selected models have thick black f rames). A dialog window is presented to 

ask for the root part of  all selected Catia-Models: 

 

Figure 10: root Part for neighbourhood search. 

After pressing the OK-Button, the neighbourhood search starts, and all neighbour models 
of  all the selected Catia Models are presented in the Workbench under the same root 

Part. All clicked Catia Models are highlighted in the workbench. 

 

 
Only Catia Models with Bounding-Boxes are searched. 

Prior to the Neighbourhood-Search a CMI-DMU-File must be created for the root-

Part via the Workbench-Action > “Create DMU-File” 

You can modify the extent of  the neighbourhood by changing the DMU-Tolerance in 
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the DMU-Preferences. That means the bounding box values of  the selected Catia-

Model are augmented with the DMU-Tolerance. (Default = 0.0) 

 

The menu item Query > DMU > “Show Models of  DMU-Volume” presents a Dialog-

window to ask for the root Part and for the DMU-Volume: 

 

Figure 11: Dialog for selection of root and volume. 

If  you click the selection box for the root part, all Part Numbers and Revisions are shown 
for which a CMI-DMU-File exists. When the root part entry is set, a click on the volume 

name for Part selection box shows all Volumes for this specif ic root Part.  

If  there is no volume that meets your requirements for the root Part, you can perform a 

dynamic “Volume Search” by specifying all bounding box values in the dialog window.  

When pressing the OK button, the Volume search begins, and all Catia models within the 

selected Volume will be shown in the Workbench under the same root Part. 

 

 
Only Catia-Models with Bounding-Boxes are searched. 

Prior to the Volume-Search a CMI-DMU-File must be created for the root Part via 

the Workbench-Action > “Create DMU-File”. 

Prior to the Volume-Search a DMU-Volume must be created for the root Part via 

Action > “Create DMU-Volume”. 
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Menu item Options 

 

 

Figure 12: CATIA Workbench menu ‘Options’. 

The Options Menu has two Menu items the Change Preferences Submenu and the Model 

Filter Option. 

The menu item Configuration Context sets/changes the user’s configuration context.  

Within the database preferences you can def ine the query scope for the databases to be 

searched in. 

If  the user wants to work with CATIA the settings at Options > CMI Preferences have to be 

set correctly.  

 

Figure 13: CMI Preferences menu 

4D Navigator Map: If  4D Navigator integration is desired user has to set path for 4D 

Navigator exchange map. 
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CATProduct Worklocation: Location where CATProducts and other f iles created f rom 

within Catia V5 are saved.  

Check WB before transfer to CATIA: If  user tries to transfer a Workbench content it will 

be checked if  it probably will not f it to the CATIA Environment Setup. This will avoid an 
unsuccessful attempt of  transferring a lot of  data that may cause an error message or 

even a CATIA system crash. 

Show last model sequence in Saved Session: Is this button set, saved session is 

reloaded with the newest sequences of  models in CATIA Workbench. 

Use CATIA V5 files : CATDrawings and CATParts are sent to CATIA V4 / V5  This 

attribute was labelled Enable CATIA V5 files in former releases. 

Use CATIA V4 files : CATIA V4 Models are sent to CATIA V4 / V5  

Work with CATIA: User can choose between work with CATIA V4 or CATIA V5. 

Drop with multilevel-expand: Automatic expand of  the product structure when an 

Assembly is dropped onto the Workbench 

Transfer CGR-Files to CATIA V5: Preference allows user to send CGR f iles to CATIA V5 

(see Working with CATIA V5 Released Cache).  

Transfer model-files to CATIA V5: Preference allows user to not send model f iles to 
CATIA V5. Usually this preference should remain not set or true. It is used with the 

optional Get original geometry from Teamcenter feature in Catia V5. 

For further information about working with CATIA V5 please read the CMI Preferences 

chapter for CATIA V5. 

 

 
Use the ‘Check WB before transfer to CATIA’ preference only when you are 
handling very large CATIA-Sessions, because it will reduce the interface 

performance. 

 

DMU Preferences 

If  user wants to use DIGITAL MOCKUP (DMU) you can change the tolerance (extension) 
of  the bounding box for the neighbourhood-search via the DMU Preferences menu option. 

This tolerance is added to all bounding-box-values of  the selected Catia-Model. 

 

Figure 14: DMU Preferences menu 

Model Filter 

The Menu item Model f ilter will start the Model Filter preferences Dialog (Figure 15), which 

is used to set the actual Model Filter. 
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Figure 15: Model Filter Preferences dialog 

The Use model filter option will def ine, if  the Filter should be used. If  the Filter is Used, the 
selected Model types will pass in the Expand Function of  the CATIA Workbench, 

unselected Model types will be f iltered. 

Filter  for public versions 

If  the Filter for public versions is activated, only private and public Catia-Files are 

transferred to Catia. Private means that the f ile is owned by the actual user, public means 
that the f ile is checked in to a vault. If  there is a checked out f ile of  another user during “To 

Catia”, the latest public predecessor f ile is transferred to Catia, if  existent. 

Menu item View 

 

Figure 16: CATIA Workbench menu ‘View’. 

The menu item View displays items in the CATIA Workbench in list view or in tree view. 
You can also modify the list view columns or sort the items. Finally you can choose 

whether models are to be displayed within the CATIA Workbench or not. 

For more information about the entries, please refer to:  
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Help > Menu 

Menu item Help 

 

Figure 17: CATIA Workbench menu ‘Help’. 

The menu item Help displays information about your session, about the menus and their 

meaning. Additionally CMI product information can be displayed. 

 

Pop-Up menus of Workbench Items 

If  you select a ‘Part’ or a ‘Document’ or a ‘CATIA Model’ and drop it into the CATIA 
Workbench, a new object will be created dynamically. The new created icon represents 

the CATIA relevant data of  the dropped object. The icons in the Workbench are the same 
as in the Standard Teamcenter Enterprise browsers, with an additional arrow on the 
lower lef t corner indicating that this item is to represent an originating Teamcenter 

Enterprise object. 

Parts in the Workbench 

On the ‘part representants’ displayed in the Workbench browser there are the following 

functions available: (notice that assembly-parts and component-parts use the same icon.) 

 

Figure 18: Context menu on Part in Workbench 
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Pop Up Menu Item Description 

Mark/Unmark Part           :  Marks the selected part representant 
Mark All Subassemblies          : Marks the part and all subassemblies 

Unmark All Subassemblies.     : Unmarks the part and all subassemblies 
Get Item Info                        : Displays extended part representant information 
Refresh                                     :  Refreshes the displayed attributes of  the part 

representant 
Set Work plane                        : Sets the working plane to the selected part 

representant 

Highlight in CATIA Marks the selected part in CATIA 
Expand Multiple Levels           : Expands the part relationship until the last level 
Expand for Visualization          : Expands the part relationship until the last level, if  

visualizations are found, the level expand is stopped 
and only the visualization is expanded. 

Expand                                     : Expands the part item relationship in one level 

Expand Models                        : Expands only the models attached to the part 
Expand V5 Drawings               : Expands any CATDrawings attached to the Part 
Show Relationship >                 

      Is Described By                 : 

Displays related Documents 

Show Relationship  >                
      Attached Black Box Files  : 

Displays any Black Box f iles attached to the Part  

Deexpand Branch                   : Removes the selected part or assembly including all 
subassemblies  

 

Documents in the Workbench 

For the “document representative” displayed in the Workbench browser there are the 

following functions available:  

 

Figure 19: Context menu on Document in Workbench 

 

Pop-Up Menu Item Description 

Get Item Info               : Displays extended document representative information 
Refresh                            : Refreshes the representation of  the document  
Expand                            : Expands the related models 

Deexpand Document  : Removes the selected document including all related models 
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Models in the Workbench 

Context sensitive to the “model representatives” displayed in the Workbench browser 

there are the following functions available: (notice that you can decide to show or to hide 
the model representative with the toggle ‘View > Display Models’.) 

 

Figure 20: Context menu on Model in Workbench 

Pop-Up Menu Item Description 

Mark/Unmark Model    : Marks or unmarks the model representative 
Get Item Info    : Displays extended model representative information 

Refresh    : Refreshes the representation of  the model 
De-expand Model    : Removes the selected model 
Highlight In CATIA    : Highlights the selected model in CATIA 

Draw Flag On/Off     : Toggles the Draw-Flag 
Swap Flag On/Off     : Toggles the Swap-Flag 
Activate Model    : Marks the model to be the active model in CATIA 

Show Neighbour Models  : Marks the neighbour models in Workbench  
(needs DMU Export File see Figure 11) 

 

The model representative in the Workbench shows information about the model f ile and 

the f lags you have set: 

 

File name 

Description 

Sequence File size (byte) 

Draw Flag Swap Flag 

 
 

“Show Neighbour Models” performs the Neighbourhood-Search for the clicked CATIA-
Model. If  the complete path f rom the Root-Part to the clicked CATIA-Model is in the 
Workbench, and there exists a CMI-DMU-File for the Root-Part, the search is done 

immediately. Otherwise a Dialog-window is presented to ask for the Root part of  the 

selected CATIA-Model: 

 

Figure 21: Select Root Part for Neighbourhood 
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By pressing the OK-button, the neighbourhood search starts and all neighbour models of  
the selected Catia models are presented in the Workbench under the root Part. The 

clicked Catia model is highlighted in the workbench. 

 
You should use this functionality only for f rozen data. Therefore use the 

conf iguration context to use only f rozen data. 

 

 
Only Catia models with bounding boxes will be searched. 

Prior to the “Neighbourhood Search” a CMI-DMU-File has to be created for the root 

Part via the Workbench-Action > “Create DMU-File” 

You can modify the extent/size of  the neighbourhood by changing the DMU-
Tolerance in the DMU-Preferences. That means the bounding box values of  the 

clicked Catia model will be increased by the DMU-Tolerance. (Default = 0.0) 
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CHAPTER 4 

General Functions 
This chapter describes how to handle CATIA relevant data in Teamcenter Enterprise. It 
describes operations, such as creating CATIA models and assembly structures, as well as 

how to search for them. 

 

Predefined Object Structure 

The CATIA Teamcenter Interface (CMI) contains the following predef ined object structure: 

 

D o c u m e n t  C A T I A  M o d e l  1  

C A T I A  M o d e l  2  

C A T I A  M o d e l  n  

D e s c r i b e d  b y  a t t a c h e s  

C A T I A  M o d e l  

M o d e l h a s P l o t F i l e  

P l o t  

F i l e  

… 

P a r t  

 

Figure 22: Predefined CATIA model structure. 

For each part a relation ‘described by’ with a document element must exist. The 
relationship can be created by dragging any document object and by dropping it to the 

part object. Please refer to the Teamcenter user documentation for managing 
relationships between Teamcenter elements. The documents can contain at least one 
relation ‘attaches’ with CATIA model elements. You can attach more than one CATIA 

model to a single document, and more than one document can be associated with each 
part. Any CATIA model object can contain one relation ‘Model has plot f ile’ with any plot 

f ile, which can be created f rom CATIA.  

Document CATIA Model 1

CATIA Model 2

CATIA Model n

described_by attaches

CATIA Model

ModelhasPlotFile

Plot File

...

Part

 

Figure 23: Plot file attached to a CATIA model. 
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All of  the elements and the relations between them can be customized. For more 

information please refer to CATIA Teamcenter Interface Customizing Documentation. 

 

CATIA V4 Templates  

CATIA V4 templates are so-called predef ined empty CATIA V4 models. They are useful if  
you want to use CATIA V4 models with the same settings and predef ined views, such as 

project environment and title block settings for drawings. CMI prevents you f rom creating a 

new CATIA V4 model object without a CATIA V4 template object. 

Templates are always generated by registering f ile item objects as CATIA Templates. This 

work is generally done by your administrator.  

 

Figure 24: Registering an existing CATIA V4 model as CATIA V4 Template 

You can copy an existing CATIA V4 model to your Template location and register it as a 

CATIA V4 Template object as shown above.  

The registered CATIA Templates may then be used to create new CATIA model objects.  

 

Creating a CATIA V4 Model 

From the Menu Bar in Home Collection select: 

 
Create > CATIA Files > CATIA V4 Model 

A dialog window as the one below appears.  

Fill in the field  ‘File Name’ 
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Fill in the field ‘Work Location’. 

 

 

Figure 25: Dialog ‘Create CATIA V4 Model’ 

 
Push the square button beside the fields  ‘Work Location’ or ‘Template’ to choose 
f rom a list of  possible values. If  there is only one possible value, pushing the button 
will f ill in the field automatically. 

 

Fill in the field ‘Template’. CATIA templates are CATIA models, predef ined by the 

administrator, used as a basis to create other CATIA models.  

 

If  the ‘Description’ field has not been f illed the Warning ‘Description of  CATIA-Model is 
missing!’ appears on the status line. 
 

 
It is useful and recommended to f ill in the ‘Description’ field, because this value will 

appear in the Window menu of  the Motif  CATIA User Interface af ter the model has 
been loaded via the CMI interface. 
Further on the dialog for i.e. METAPHSE>UPDATE>ALL menu option will not list 

CATIA models without this description. You will see ‘-’ instead of  the names. 
 

Press Ok. 
 

 
It is possible to open a new browser window containing the recently created ‘CATIA 

Model’ object by selecting it and choosing:  Window >Browse Selected Items. 
 

 

Creating a CATIA V5 CATPart  / CATDrawing 

From the Menu Bar in Home Collection select: 

 
Create > CATIA Files > CATIA V5 Part File  / CATIA V5 Drawing File 
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A dialog window as the one below appears.  

Fill in the field  ‘File Name’ 

Fill in the field ‘Work Location’. 

 

 

Figure 26: Dialog ‘Create CATIA V5 Part File’ 

 
Push the square button beside the fields  ‘Work Location’ or ‘Template Vault 
Location’ or ‘Template’ to choose f rom a list of  possible values. If  there is only one 

possible value, pushing the button will f ill in the field automatically. 

 

Fill in the field ‘Template Vault Location’ and ‘Template’. CATIA V5 templates are CATIA 
V5 f iles, predef ined by the administrator in specif ic Vault Locations, used as a basis to 

create other CATIA V5 f iles. See also CMI Installation Manual 

 
If  the ‘Description’ field has not been f illed in, a warning appears in the status line. 

 

 
It is useful and recommended to f ill in the ‘Description’ field, because this value will 
be used as the part number property in Catia V5 

 

Press Ok. 

 

Creating a CATIA V4 Model from a CATIA V4 Template 

From the Menu Bar in ‘Home Collection’, select:  

 

 

Query > CATIA Files CATIA  V4 Template   

Fill in the fields with data to ref ine the search 

Press Ok. 
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Select the CATIA Template you want to use 

Use the right mouse button to get the context menu and select ‘Create CATIA 

model’ 

Fill in the f ields as described under ‘Creating a CATIA model’  

 

 

Figure 27: Teamcenter Browser Window ‘CATIA V4 Template Objects’ and popup  

 

Register Existing CATIA V4 Models 

Another way to register CATIA models is to copy your existing CATIA mo del f iles (with the 

suf f ix <.model>) to your work location. If  you open this work location in Teamcenter, the 

CATIA model f iles will then be identif ied as ‘File’ with an empty icon. 

Now you can select the CATIA models and register them as ‘CATIA-Model’. 

 

Searching for CATIA V4 Models 

In a Teamcenter Browser window, select: 

 
Query > CATIA Files CATIA  V4 Template   

Fill in the fields with data to ref ine the search. 

Press Ok. 
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Figure 28: Searching a CATIA V4 Model in Teamcenter database. 

 

Searching for CATIA V4 Templates 

In a Teamcenter Enterprise Browser window, select: 

 
Query  > CATIA  V4 Template   

Fill in the fields with data to ref ine the search. 

Press Ok. 
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Searching for  Saved CMI Sessions 

In a Teamcenter Enterprise Browser window, select: 

 
Query  > Saved CATIA Session   

Fill in the fields with data to ref ine the search. 

Press Ok. 

 

 

Figure 29: Query Saved Session. 
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Restore a saved CMI Session 

 To restore a saved CMI Session simply drag and drop the session icon into the 
CATIA Workbench. The contents of  the Workbench will automatically be restored except 
for items that are no longer valid, e.g. those parts that have been revised or removed f rom 

the structure. In these cases an asterisk (*) is shown at the parent item, to indicate that 

you might want to re-expand this item 

You can see the last sequence of  the models in saved CMI Session when the button 

Option→Change Preferences→CMI Preferences 

Set “Show last model sequence in saved session” = TRUE. 

 

Figure 30: CMI Preferences 

 

Loading Several Saved Sessions in CMI-Workbench.  

You can drag/drop additional saved CMI–Sessions into the CMI-Workbench.  
See Figure 28. 
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Figure 31 Several Saved Sessions in CMI-Workbench 

Make sure that the Configuration Context and Database Scope are set correctly so that all 

items can be found. 

 

Multilevel Auto Expand  

Due to CMIs Multilevel Auto Expand you can expand parts selectively under an assembly 
in the CATIA Workbench. To expand selectively, f irst drop the top level Assembly onto the 

Workbench without expanding it. Now drop any subassembly onto the assembly already 
in the Workbench. CMI will expand all the way to all occurrences of  this subassembly, 
without expanding unnecessary product structure. The function allows to load dedicated 

parts in context to each other, without unnecessary clutter.  

You may drop several parts at once onto a part in the CATIA Workbench. 

 

Drop with multilevel expand  

The preference Drop with multilevel expand will automatically expand the assembly 

structure if  you drop an Assembly onto the Catia Workbench.  

 In Catia-Workbench: Options>Change Preferences>CMI-Preferences 

 





 

CMI User Manual   29 

CHAPTER 5 

Working with CATIA V4 models 
This chapter describes some typical tasks such as loading documents stored in 
Teamcenter Enterprise to CATIA, updating a model, saving it under another name and 

creating plot files.  

 
All CATIA model related actions can also be used for the CATIA Template objects 
(i.e. you can load a CATIA Template in CATIA and update the modif ied model if  
your access permissions allow this action.).  

 

Reading a model from Teamcenter 

To read a CATIA model stored in the Teamcenter Enterprise PDM System: 

 

 
Start the CATIA Workbench as described in chapter 3.  

 

 
The CATIA Workbench has to be started for CATIA relevant functions (i.e. read, 
update etc.). Once the CATIA Workbench is started, you can keep this window 
open during your Teamcenter Enterprise session. 

 

 

In CATIA: METAPHSE > READ  

 

 
Any operation in the CATIA - Teamcenter Enterprise function has to be conf irmed 

by the permanent key YES in order to become ef fective in Teamcenter Enterprise. 

In this manual all the CATIA functions selections shall be immediately followed by 

this conf irmation, unless it is specif ied otherwise. 

 

 
CATIA goes to the background. The CATIA Workbench comes to the foreground. 

 

 

You can now retrieve either a document that contains one or more CATIA models or 

a single CATIA model. 

 

 

Double-click the CATIA model or Drag&Drop it in the CATIA Workbench and select 

‘ACTION > To CATIA’. The model is automatically loaded in CATIA. 
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Figure 32: Drag & Drop a single CATIA Model into the CATIA Workbench.  

 

You can also double click a document that contains one or more CATIA models or 
Drag&Drop it in the CATIA Workbench. Now you can expand / de-expand the 

models related to the document.  
 

 
If  Teamcenter Enterprise (the OMF server) and CATIA run on the same host, you 
can directly double click a model in Teamcenter to display it in CATIA. It is not 

necessary to initialize the action f rom within CATIA f irst. 

 

 

Figure 33: Drag&Drop a document into the CATIA Workbench  
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If  the selected model is in a vault, it will be loaded in ‘read only’ mode. 

 

 
You can drop more than one CATIA model or CATIA document to the CATIA 

Workbench. 

 

 

Updating a model 

After having read the document f rom the Teamcenter Enterprise database, the designer 
might carry out his activities in CATIA and might probably want  to save the changes. To 
update the model, he simply chooses: 

 

 

In CATIA: METAPHSE > UPDATE > ACTIVE 

 

 

It is not possible to update models that are already in a vault. To update these 
models, they must f irst be checked out to a Work Location. 

 

 

Saving a model under another name 

 

Create a Teamcenter Enterprise CATIA Model object with the desired name (see 

Chapter 5 of  this manual, section Creating a CATIA Model) 

 

 

Load or create your CATIA Model in the CATIA session. 

 

 

In CATIA: METAPHSE > DOCUMENT > SAVE AS 
CATIA goes to the background. 

 

 

Double click the created Teamcenter Enterprise model object or drag-and-drop it 
into the CATIA Workbench. The model that was in CATIA will overwrite the created 

document. 

 

 
It is also possible to use METAPHSE > DOCUMENT > SAVE AS for overwriting old 
models. Thus, be sure that the model to be overwritten can be deleted. 

 
 

 

It is not possible to overwrite models that are in a vault. 
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Creating a new model 

 

Load or create your CATIA Model in the CATIA session. 

 

 

In CATIA: METAPHSE > DOCUMENT > CREATE 
CATIA goes to the background. 

 

 
A Teamcenter Enterprise ‘Create CATIA-Model’ dialog window appears (Figure 26) 

 

 

Enter a model name (the suf f ix <.model> will be created automatically) and a 

description and select the work location where the model should be saved. 

 

 
Press Ok. 

 

 
If  you press ‘Apply’, the window will not close af ter creating a new model, and you 

can enter a new model name and generate another CATIA-model with the same 
content. 

 

 

Figure 34: Dialog ‘Create CATIA Model’ opened from CATIA  
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Plotting a model 

Conventions 

The CATIA Teamcenter Interface permits an automatic update of  title blocks in CATIA 
models with title block values that are retrieved f rom Teamcenter Enterprise. The CMI 
function identif ies title blocks in a CATIA model by means of  a naming convention. This 

naming convention is threefold in the way that it af fects three levels of  CATIA data in the 
model whose identif iers have to start with strings qualifying them to be constituents of  a 

title block. Those qualifying identif ier sub strings are to be def ined for 

...draf ts: if  any draf t identifier starts with the qualifying string the CMI function continues to 

search for ... 

...views: if  any view identif ier starts with the qualifying string the CMI function continues to 

search for dittos referring to ... 

...details: if  any detail identif ier starts with the qualifying string def ining a title block the CMI 
function retrieves all values def ined for this title block f rom Teamcenter and displays them 

in the corresponding view positions. 

There is only one (conf igurable) start string for draf ts and one other for views but there 
may be a multitude of  strings for details (as many as dif ferent title blocks) def ining their 

corresponding title blocks. Thus the need for probably many dif ferent title blocks in a 

company is covered. 

The following f igure shows a simple draf t with the name conventions used by the CATIA 

Teamcenter Interface: 

 

Figure 35: Naming conventions for drawing sheets 

Example for a drawing sheet 

In the following we describe a sample, which f its to the conventions that we need to def ine 

in the f ile appdefault.obj. This f ile must be located in a path that can be found in $PATH. 
You can f ind a sample for this f ile in the CATIA part of  your CMI installation: 

.../catedm/data/appdefault.obj. 

In this example (in appdefault.obj following the keyword “@frame-option”) we will def ine a 
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Draf t named “BLATT”  (in appdefault.obj the value following the keyword  “indicatordraf t”), 
a  View named  ”FRAME” (in appdefault.obj the value following the keyword 
“indicatorview”) and Details like “DIN A0” and ”DIN A1” (in appdefault.obj one of  the values 

following the keyword “f rames”) a.s.o. Each Detail represents a possible title-block which 

is to contain values out of  the PDM-System. 

 

Catedm/data/appdefault.obj 
@general-options 

{connectmethod} xtitle CMI  

{exchangemap} /tmp 

{exchange_dlname} CATIA.$USER.MP01.MAP 

{logfile} stdout 

{modelnametype} 1 

{modrenallowed} 1 

{geoposallowed} 0 

{edbapphost} $HOST 

{debug} 0 

{project} UNKNOWN 

{catiaversion} 422 

{tmpaxis} 1 

{tmpaxis-dlname.example} CATIA.STANDARD.MP01 

{tmpaxis-name.example} CATIA_START_MODEL 

{wpmodus} 0 

{connectx-script} dshgui_find.sh 

{normpart-support} 0 

{assembly-symmetry} 1 

{modellinks} 1 

{license-startscript} licman12 

{autorefresh} 0 

{lld-autostart} 1 

{load-warning} 1 

{merge-support} 1 

{remove-models} 1 

{newupd} 1 

{replace-model} 1 

{cmi-custom-update} 3 

{bbox-support} 0 

{bbox-layer-list.example1} 0 1 2 3 4 5 6 7  

{bbox-layer-list.example2} -1  

 

@frame-option 

{redraw-default}  yes 

{indicatordraft}  BLATT 

{indicatorview}   FRAME 

{standard-format} ISO 

{frames} {DIN A0} {DIN A1} {DIN A2} {DIN A3} {DIN A4} 

{definition-script} dshdrawingframe.sh 

 

@plot-option 

{create-plotfile} yes 

{plotformat} IBM-GL 

{sizeX} 1189.0 841.0 594.0 420.0 210.0 

{sizeY} 841.0 594.0 420.0 297.0 297.0 

{orientation} V 

{plottracefile} /tmp/$USER.plottrace 

{plotinfile} /tmp/$USER.plotin 

{plotconffile} $CATEDM_SCRIPTDIR/plotconf 

 

@helper-object 

{helper} xpdf -z 2 -g 890x700 -remote xpdf -raise -title "CMI User Manual" 

{alias} /../../metaphse_4.x.x/pdfdoc/userman.pdf 
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The values for sizeX and sizeY in appdefault.obj following the keyword “plot-option” must 
be written in the order of  above Detail-names. Thus each value pair corresponds to one of  
the title blocks (def ined by its detail-name) appearing at the same sequential position af ter 

the already mentioned keyword “f rames”. In our example the title block corresponding to 
the detail “DIN A0” has coordinate values x=1189.0 and y= 841.0, the title block 
corresponding to the detail “DIN A1” has coordinate values x=841.0 and y=594.0 a.s.o. 

Those coordinate values refer to the axis-system of  the CATIA-view (the view in our 

example was named “FRAME”) and def ine the size of  such a titleblock. 

 

Now we create a CATIA model with the CATIA Teamcenter Interface and CATIA that f its 
to the previously explained naming conventions thus allowing to automatically update 
titleblock contents with their corresponding values out of  the PDM-System   (see 

appdefault.obj): 

 

 

Load a CATIA model which should be used as root model 

METAPHSE > READ 

 

 

Double-click the CATIA model, or Drag&Drop it in the CATIA Workbench and select 

ACTION > To CATIA. The model will be loaded in CATIA. 

 

 

Split CATIA screen into ‘DRAFT’ and ‘3D’ with 

IMAGE > SCREEN > DEFINE 

 

 

Create a ‘Draf t’ with DRAFT > CREATE 

SP (SPace (3D)) > DR (Drawing): Drawing mode has to be activated !!! 

(has to be done in the ROOT model, name e.g. ‘Blatt’ !!!) 

 

 

Create geometry (e.g. a ‘PLANE’) 

DR> SP: 3D Space mode has to be activated !!! 

 

 

Create a 2D point in your new created Draf t POINT> COORD 

SP> DR: Drawing mode has to be activated !!! 

 

 

Create ‘View’ with 

AUXVIEW> CREATE functionality. 
 

SP> DR: Drawing mode has to be activated !!! 
Describes the projection to the plane created before. 
 

SELECT LINE/ PLANE (created in point 5) 

SELECT POINT (created in point 6) 

KEY VIEW ID (e.g. ‘FRAME’) 

 

 

Create a ‘Detail’ with DETAIL> CREATE 

KEY DETAIL ID (name e.g. ‘DIN A3’) 

Select in your 2D View (created with AUXVIEW) a Line/ Point to create a ‘Ditto’ onto 

this view 
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Save the model with METAPHSE > UPDATE > ACTIVE 

How to def ine the contents to be shown in a title block? 

Beneath the keyword “@frame-option” in appdefault.obj the keyword “def inition-script” 
indicates the name of  the script which def ines the PDM-contents of  the title-blocks 

(“dshdrawingframe.sh” in the example provided on delivery of  CMI).  
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Catedm/bin/dshdrawingframe.sh 
#!/bin/sh 

# -------------------------------------------------------------------------

---- 

# this is an example shell-script 

# 

# usage: drawingframe [frame-name]  

# 

# It creates a set of entries which are used e.g. from CATIA 

# 

# The output must have a certain format 

# {string {@text}} {xpos 0.0} {ypos 0.1} {font font} {orientation 0} {color 

0} 

# {size 5.0} {width 3.5} {slant 0.0} {space 1.5} {linetype 1} {thickness 

0.35} 

# {justification 9} 

# 

# description  : 

# 

# string       : mandatory 

#                free text e.g. "this is a text" 

# xpos, ypos   : mandatory 

#                text position; real values e.g 10.0  

#                belongs to view axis system 

#                default: xpos = 0.0, ypos = 0.0 

# font         : graphical representation e.g. CHR_DSFT 

#                ATTENTION: some other attributes may depend on this 

attribute 

#                default: like defined in standard 

# orientation  : 0 -> horizontal, 1 -> vertical 

#                default: 0 

# color        : = 0 -> no 

#                = 1 -> white 

#                = 2 -> red 

#                = 3 -> green 

#                = 4 -> blue 

#                = 5 -> yellow 

#                default: 1 

# 

# width        : mandatory 

#                real value e.g. 3.0 

#                default: 3.5 

# size         : height of text, real value e.g. 5.0 

#                if size is set to 0.0 the text height is linked to the 

width 

#                default: 5.0 

# slant        : degrees, real value, must be between 0.0 and 45.0 

#                default: 0.0 

# space        : space between text characters, real value 

#                default: 1.0 

# linetype     : = 1 -> no scoring 

#              : = 2 -> underscoring 

#              : = 3 -> scoring 

#              : = 4 -> overscoring 

#                default: 1 

# thickness    : real value, e.g. 3.0 

#                default: 1.0 

# justification: 0-9, text justification 

#                = 0 -> default justification is middle left (2) else 

#                [1][4][7] 

#                [2][5][8] 

#                [3][6][9] 

# 

# exit values must be 

# 0  everything was fine 

# 1  failed 

# 2  unknown frame-name 

# -------------------------------------------------------------------------

---- 
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if [ $# -le 0 ] ; then 

  exit 1 

fi 

 

TOKEN=$1 

 

# echo "TOKEN=$TOKEN" 

 

# case $TOKEN in 

 

#   "DIN A0") 

     echo "{string {Created:  @Date}}             {xpos 70} {ypos 15} {font 

CHR_DSFT} {color 1} {orientation 0} {size 8.0} {width 0.0} {space 0.1} 

{slant 0.0} {linetype 2} {thickness 4.0} {justification 1}" 

     echo "{string {Modified: @ModificationDate}} {xpos 60} {ypos 15} {font 

CHR_DSIS} {color 2} {orientation 0} {size 8.0} {width 0.0} {space 0.5} 

{slant 0.0} {linetype 1} {thickness 5.0} {justification 2}" 

     echo "{string {Name: @Name}}                 {xpos 40} {ypos 15} {font 

EUDT_VCF} {color 3} {orientation 0} {size 2.0} {width 0.0} {space 0.5} 

{slant 0.0} {linetype 1} {thickness 1.0} {justification 3}" 

     echo "{string {User: $USER}}                 {xpos 20} {ypos 40} {font 

CHR_DSIS} {color 4} {orientation 0} {size 2.0} {width 0.0} {space 0.5} 

{slant 0.0} {linetype 1} {thickness 5.0} {justification 2}" 

#     ;; 

 

#   *) 

#     exit 2 

# esac 

 

exit 0 

 

 

In this shell script drawingframe  (to be found in directory 'catedm/bin') the user is to def ine 
the entries (PDM-contents) for his previously def ined views (like „DIN A0“, “DIN A1” 
a.s.o). In this example the view name (“DIN A0”) is put in comment “#”. Thus all 

subsequent entries would apply to just any titleblock def ined by one of  those views (“DIN 

A0”, “DIN A1” a.s.o.) not only to “DIN A0”. 

Such a view might contain several entries. An entry for an example looks like the 

following:  

{string { “Company Name“ }}            {xpos -380} {ypos 0}  {size 10} 

{string {Created: @Date}}              {xpos 2}    {ypos 62} {size 1} 

{string {Modified: @ModificationDate}} {xpos 2}    {ypos 42} {size 1} 

{string {Name: @Name}}                 {xpos -0}   {ypos 5}  {size 1.5}  

                                       {color 3} 

{string {User: $USER}}                 {xpos -20}  {ypos 2}  {size 3}   

{orientation 1} 

In general those entries represent constant values like “Company Name”, values delivered 

f rom the environment like “User” and values coming out of  the PDM like Modif icationDate.  

Those entries representing values out of  the PDM are preceeded by “@”. These values 
will be provided by means of  the customizable x3GetAttrsForCAD CMI method which will 

be described soon. 

Each view section in the drawingframe script f ile can contain the following entries within a 

single line: 

Statement Syntax Description 

Xpos {xpos x} x position of  text entry 

Ypos {ypos y} y position of  text entry 

Size {size s} size of  text entry 

Color {color c} color of  text entry 
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Orientation {orientation o} orientation of  text entry 

String {string {sub string} } text entry. 

 

 

The sub string can contain following statements: 

Statement Example Description 

“string“ “T-Systems“ The string will be written into the drawing 

String T-Systems The string will be written into the drawing 

$<var> $USER The UNIX user name will be written into the 

drawing 

@<var> @Date The alias name for the x3GetAttrsForCAD 
message. In our example listing it is the alias 

name for the Teamcenter attribute 

“CreationDate“. 

 

How to get values f rom the PDM-System into one of  the def ined titleblocks (like DIN A0, 

DIN A1 a.s.o) automatically on reading the model via CMI? 

The parameters that begin with "@" are those coming f rom PDM and are thus relevant for 

the customization. In this case, the parameter list:  

 Date 

 Modif icationDate 

 Name 

will be transferred to the x3GetAttrsForCAD CMI method as Attrs_demanded string list. 
Now this string list can be scanned; for each custom parameter the variable 

AttrVals_found is extended and given back to the CMI server. The CMI server can now 
actualize all those titleblocks containing these entries with the most recent database 

information. 
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PdmItem: x3GetAttrsForCAD 
DOCBEGIN 

 ****************************************************************************** 

 *                                                                            * 

 * Method/Function    x3GetAttrsForCAD                                        * 

 *                                                                            * 

 * Class              PdmItem                                                 * 

 *                                                                            * 

 * Description        Handles the x3GetAttrsForCAD message for the PdmItem    * 

 *                    Message type is an object message.                      * 

 *                    This method delivers a set of attribute values found    * 

 *                    for a set of demanded attribute types.                  * 

 *                    It is called immediately after a Model Read in case the * 

 *                    Model read is structured in accordance to a drawing-    * 

 *                    frame defined in the script "drawingframe".             * 

 *                    The method  provided on deliverance of CMI serves as an * 

 *                    example showing how "drawingframe" and                  * 

 *                    "x3GetAttrsForCAD" are supposed to cooperate. In        * 

 *                    practical use this method will be overwritten in the    * 

 *                    course of customization.                                * 

 *                                                                            * 

 * called within      x0WkBnch:x3GetAttrs                                     * 

 *                                                                            * 

 * Language           C                                                       * 

 *                                                                            * 

 * Input Parameters                                                           * 

 *   Type          | Name           | Description                             * 

 *   --------------+----------------+---------------------------------------- * 

 *   ObjectPtr     | this           | PdmItem object                          * 

 *   SetOfStrings  | Attrs_demanded | Attributes demanded by CAD system       * 

 *                                                                            * 

 * Update Parameters                                                          * 

 *   Type          | Name           | Description                             * 

 *   --------------+----------------+---------------------------------------- * 

 *                                                                            * 

 * Output Parameters                                                          * 

 *   Type          | Name           | Description                             * 

 *   --------------+----------------+---------------------------------------- * 

 *   SetOfStrings  | AttrVals_found | Values for demanded attributes          * 

 *   integer       | mfail          | method success/ failure status          * 

 *                 |                |   0 - (USC_OKAY) - successful           * 

 *                 |                |   !0- unsuccessful                      * 

 *                                                                            * 

 * Return Value                                                               * 

 *   --------------+----------------+---------------------------------------- * 

 *   status        | dstat          | OKAY                   - Success        * 

 *                 |                | NOT_OKAY, BAD_PARAMETER- Failure        * 

 ****************************************************************************** 

 DOCEND 

 */ 

message PdmItem:x3GetAttrsForCAD ( 

   input : ObjectPtr    this           :: 

   input : SetOfStrings Attrs_demanded :: 

   output: SetOfStrings *AttrVals_found :: 

   output: integer      *mfail) code 

{ 

   /* ---------------------------------------------------------------------- */ 

   /* Declaration of variables                                               */ 

   /* ---------------------------------------------------------------------- */ 

   string  attr_type= NULL; 

   string  value    = NULL; 

 

   integer numVal   = 0; 

   integer i        = 0; 

 

   /* ---------------------------------------------------------------------- */ 

   /* Begin                                                                  */ 

   /* ---------------------------------------------------------------------- */ 

   MPDBXFSTART ("PdmItem:x3GetAttrsForCAD") 

 

   /* ---------------------------------------------------------------------- */ 

   /* Initialize return values                                               */ 

   /* ---------------------------------------------------------------------- */ 

   *mfail= USC_OKAY; 

 

   numVal= setSize (Attrs_demanded); 

   if (!numVal) { 

      goto CLEANUP; 
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   } /* end if (!numVal) .. */ 

 

   *AttrVals_found = setCreate(setSize(Attrs_demanded)); 

 

   /* ---------------------------------------------------------------------- */ 

   /* Get Attributes; before, inflate dynamic attributes                     */ 

   /* ---------------------------------------------------------------------- */ 

   dstat= InflateDisplayedName (this, mfail); 

   CHECK ("InflateDisplayedName") 

 

   for (i= 0; i< numVal; i++) { 

      attr_type= setGetStr (Attrs_demanded, i); 

 

      value=""; 

 

      if (STRCMP (attr_type, "Date")) { 

         dstat= objGetAttribute (this, "CreationDate", &value); 

         DSTAT ("objGetAttribute CreationDate") 

      } /* end if (STRCMP (attr_type, "Date")) .. */ 

 

      else if (STRCMP (attr_type, "ModificationDate")) { 

         dstat= objGetAttribute (this, "LastUpdate", &value); 

         DSTAT ("objGetAttribute LastUpdate") 

      } /* end else if (STRCMP (attr_type, "ModificationDate")) .. */ 

 

      else if (STRCMP (attr_type, "Name")) { 

         dstat= objGetAttribute (this, "TDisplayedName", &value); 

         DSTAT ("objGetAttribute TDisplayedName") 

      } /* end else if (STRCMP (attr_type, "Name")) .. */ 

 

      if (i<setSize(*AttrVals_found)) { 

         setPutStr (*AttrVals_found, i, value); 

      } 

      else { 

         setAddStr (*AttrVals_found, value); 

      } 

 

   } /* end for (i= 0;i< numVal; i++) .. */ 

 

CLEANUP: 

 

   /* ---------------------------------------------------------------------- */ 

   /* Free allocated memory                                                  */ 

   /* ---------------------------------------------------------------------- */ 

 

EXIT: 

 

   /* ---------------------------------------------------------------------- */ 

   /* End                                                                    */ 

   /* ---------------------------------------------------------------------- */ 

   MPDBXFEND 

   if (dstat!= OKAY) 

      dlow_return_trace (mod_name, dstat); 

   return (dstat); 

} 

; 

 

You will f ind the customizable method x3GetAttrsForCAD in custom/x3Custom.mth. This 

method is called within x0WkBnch:x3GetAttrs for Assemblies and CATIA-models. So you 

can overwrite it for your specif ic Assembly- or CATIA-Model-classes. 
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Creating a Plot File object 

The plot file object is an object that contains the information to be f illed in the draf t of  the 

model to which it is attached. To create a plot file object, perform the following steps: 

 

 

In CATIA: select METAPHSE > READ  

 

 

Retrieve or create a CATIA model, which is created with the conventions as 

described above (i.e. containing a title block).  

 

 

Double-click the CATIA model, or Drag&Drop it in the CATIA Workbench and select 

ACTION > To CATIA. The model will be loaded in CATIA. 

 

 

In CATIA, select METAPHSE > PLOT  

The plot file object is created. 

 

 

In CATIA: select METAPHSE > UPDATE > ACTIVE 

The model will be updated. 

 

 

The plot file object will be copied to Teamcenter Enterprise and registered as a plot 

file. 

The plot file object will be related to the model object by the relation: ‘Model has plot 

files‘. 

 

 
‘Model has plot files‘ is a (1:1) relationship, what means that only one plot file can 

be attached to a CATIA model and that a plot file can be attached to only one 
CATIA model. Thus, the next time a plot file is created, the existing object in 
Teamcenter Enterprise will be overwritten. 
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CHAPTER 6 

Working with Structures 
This chapter explains the concepts underlying the work with structures and describes how 
to create assemblies and components, search for parts, load parts in CATIA and modify 

the structure position. 

 

Understanding the Structure  

A structure is made of  one or more parts. Teamcenter Enterprise knows two kinds of  

parts, 

Assemblies: 
 

and Components: 

 

 

An Assembly is a Part that can contain other Parts (i.e. Assemblies or Components). A 

Component cannot contain other Parts. 

Please refer to the ‘Figure 23: Predef ined CATIA model structure.’ on page 19 for more 

information about a default assembly data structure.  

 

Creating a Part 

Creating an assembly 

 

In a Teamcenter Enterprise browser window select: 

Create >Product Structure Classes > Assembly 

Creating a component 

 

In a Teamcenter Enterprise browser window select: 

Create >Product Structure Classes > Component 

 

Searching for Parts 

Searching for Assemblies 

 

In a Teamcenter Enterprise browser window select: 

Query > Product Structure Classes > Assembly 
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Searching for Components 

 

In a Teamcenter Enterprise browser window select: 

Query > Product Structure Classes > Component 

 

Creating a Structure 

To create a structure in Teamcenter Enterprise, the parts of  the Assembly need to have 

been created (see the section Creating a Part in this chapter). 

A relation ‘uses part’ is generated by dragging and dropping the ‘used’ part onto the part 

that uses it. 

For example: to create the relationship ‘Part 1 uses part Part 2’ just drag-and-drop Part 2 

onto Part 1. 

The relationships need not to be made in a specif ic order. For example, the two steps to 

create the structure of  the f igure below are interchangeable:  

drag-and-drop Part 3 onto Part 2   

drag-and-drop Part 2 onto Part 1 

 

Figure 36: A simple assembly structure. 

 

Please refer to the Figure 21: Predef ined CATIA model structure on page 19 for more 

information about the default assembly data structure.  

The f igure below shows an example assembly in tree view where Document objects and 

model objects have also been created and related to the Part objects: 

 

Figure 37: Example of an expanded Assembly in Teamcenter Enterprise browser.  
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Example Structure for CMI 

The following instructions describe step by step how to create an example assembly 

structure which can then be loaded into the CATIA session:  

 

Figure 38: Example assembly structure in Teamcenter Enterprise browser.  

 

 

 

Create the following Assembly objects: 

 
A_FrontWheel 

A_Brake 

A_Suspension 

DrivingShaf t 

Inner_Mudguard 
WheelCarrier 
BrakeDisc 

BrakePiston 
LowerTraverse 
UpperTraverse 

TraceBar 

 

 

 

 

Create the relationships between the Assembly objects like you can see in the f igure 

above. 

Tip: Af ter Drag  Drop; Expand Relationship\Uses Parts 
 

 

 

 

Create the following Document objects for the following Assembly objects:  

DrivingShaf t 
Inner_Mudguard 
WheelCarrier 

BrakeDisc 
BrakePiston 
LowerTraverse 

UpperTraverse 

TraceBar 

 

Create the relationships between the Assembly objects and the corresponding 

Document objects as listed above (i.e. Drag & Drop the Document ‘DrivingShaf t’ 
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onto the Assembly ‘DrivingShaf t’) 

Tip: Af ter Drag  Drop; Expand Relationship \Is Described By  

 

Register the example native CATIA f iles included in the distribution (ask your 

administrator, if  you do not have those f iles) as CATIA V4 Models.  

Tip: The CATIA f iles have to be stored in the users Worklocation 

 

 

Create the relationships between the Document objects and corresponding CATIA 

Models (i.e. Drag & Drop the CATIA Model ‘DrivingShaf t’ onto the document 

‘DrivingShaf t’) 

 

The so created product structure you can now put into the CMI Workbench and expand it 

(see f igure below). Then you can send it to CATIA. See the following chapters. 

 

Figure 39: Example assembly structure within CMI CATIA Workbench. 

 

Loading a Structure in CATIA 

To load an assembly structure in CATIA: 

 
Start the CATIA Workbench as described in chapter 3. 

 

 
The CATIA Workbench has to be started for CATIA relevant functions (i.e. read, 

update etc.). Once the CATIA Workbench is started, you can leave this window 
open during your Teamcenter Enterprise session. 

 

 

In CATIA: METAPHSE > READ  (conf irm with “yes”) 

CATIA goes into the background.  
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The CATIA Workbench comes to the foreground. 

 

 

Drag & Drop the Part that is the ‘root’ of  the selected structure in the CATIA 

Workbench (or double-click it). 

 

 

Figure 40: Drag & Drop an assembly into the CATIA Workbench. 

 
Select ‘Part 1’ in the CATIA Workbench. Choose the ‘Expand’ option in the Pop-Up 
menu of  the part. The parts that are used by the selected assembly appear. You can 

expand one level or multiple levels (Caution: if  you have created complex assembly 

structures, this action may need some time to expand all levels of  the assembly).  
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Figure 41: Expanded assembly structure in CATIA Workbench 

 
It is also possible to choose the Expand Multiple Levels function with the 
‘View’→‘Display Models’ option. In this case, the structure shown in the CATIA 

Workbench is the same as before, plus the models. 

 

 

Figure 42: Expanded assembly structure with models in CATIA Workbench 

 

 

You can now decide to either load the whole assembly, or to load the assembly with 
only a selection of  sub-components/parts. To exclude a subpart f rom being loaded 

into CATIA, select the part and hide it with the Deexpand option in the popup menu  

 

 
In the CATIA Workbench, select the option Action > To CATIA in the menu. The 

assembly is transferred to CATIA 

 

 

Af ter having transferred the data, the CATIA session appears with the desired 

assembly structure. You can modify the assembly and save it in Teamcenter. 
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You can drop more than one part or assembly to the CATIA Workbench. It is also 
possible to mix parts and assemblies with CATIA models or documents.  

 

 
If  you drop another part onto a part in the CATIA Workbench instead of  onto the 

background, and the dropped part is a subassembly, it will be expanded.  
You can use this to expand only selected subassemblies, to avoid expanding a 
complex structure only to de-expand most of  it af terwards. For further information 

please refer to the section entitled “Multilevel”. 

 

Highlighting a Model in CATIA 

In cases where you have loaded an assembly structure to CATIA as described in the 
steps above, it may be useful to f ind the equivalent model in the CATIA session of  a 

Part/model displayed within the CATIA Workbench. 

For this purpose, it is possible to highlight CATIA models in CATIA using the currently 

selected Model in the CATIA Workbench. 

Model highlighting is also available in CATIA V5 CMI. 

 

In the CATIA Workbench, select the CATIA model you want to be highlighted in the 
CATIA session and choose the Highlight in CATIA option in the Pop-Up menu. CATIA 

comes to the foreground with the selected CATIA model highlighted. 

 

 
Since this option is only available at CATIA models in the CATIA Workbench, you 
have to expand the assembly structure with the ‘Show Models’-option before 
transferring the assembly to CATIA. 

 

 

Updating a Structure 

There are 3 ways to update a structure: 

 

In CATIA: METAPHSE > UPDATE > ACTIVE  

Updates the active model (geometry information) 

  

 

In CATIA: METAPHSE > UPDATE > GEOMETRY 

Updates the geometry information of  all activated models. 

  

 

In CATIA: METAPHSE > UPDATE > POSITION 

Updates the position information of  all changed positions.  

 

 

There are two restrictions that shall be considered: 
If  a model related to a part of  the structure is in a vault, this model cannot be 
modif ied (for example it is not possible to change its color). Despite of  this it is 

possible to modify the relative position between this part and the others (the 
position data is stored in the part relation object). 
If  a part of  the structure is in a vault, the model related to this part can be modif ied 

(if  it is not checked in) but there is no way of  changing the position of  this part 
relative to its subparts. 
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Rereading a Structure 

If  you choose METAPHSE > READ in CATIA the modif ications to models and positions that 
you currently have in CATIA will be lost. To send additional data to CATIA or to restore 

only part of  your data (e.g. to undo changes) you can use METAPHSE > REREAD  

There are 3 ways to reread a structure: 

 

In CATIA: METAPHSE > REREAD > GEOMETRY  

Reads the current content of  the CATIA Workbench. Rereads all models but does 

not read positions that are already in CATIA.  

Items that are no longer in the Workbench will be removed f rom CATIA. Items added 

to Workbench will be also added to the CATIA Session.  

  

 

In CATIA: METAPHSE > REREAD > POSITION  

Reads the current content of  the CATIA Workbench. Rereads all positions but does 

not change models that are already in CATIA.  

Items that are no longer in the Workbench will be removed f rom CATIA. Items added 

to Workbench will be added also to the CATIA Session.  

  

 

In CATIA: METAPHSE > REREAD > RESYNC  

Reads the current content of  the CATIA Workbench. Reads only models that are not 
already loaded in CATIA, but does not change any existing positions and models. 
Items that are no longer in the Workbench will be removed f rom CATIA. Items added 

to Workbench will be also added to the CATIA Session. 

 

 
If  you want to add or remove few items f rom CATIA you can use METAPHSE > 
REREAD > RESYNC.  This is faster than the other options as CATIA does not load 

items that are already loaded . 

 

 

Working with marked Parts 

To speed up your work with the CATIA Workbench it is possible to mark parts, assemblies 

or models. Marked items are shown with a blue icon.  

It is possible to apply the following functions to the marked items:  

 
In the CATIA Workbench: Action > Marked Items > Deexpand Marked Items 

All marked items and sub-items are removed f rom the CATIA Workbench. 

  

 
In the CATIA Workbench: Action > Marked Items > Unmark All 
All items are set to the unmarked state. 

  

 
In the CATIA Workbench: Action > Marked Items > Marked Items to CATIA 

All marked items are sent to CATIA. 

 
If  Teamcenter (the OMF server) and CATIA run on the same host, you can use this 
command directly. Otherwise you have to initialize the communication f rom CATIA 
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with METAPHSE > READ or METAPHSE > REREAD f irst. 

  

 
In the CATIA Workbench: Action > Marked Items > Highlight Marked Items 

All marked items and sub-items are highlighted in CATIA. 

 

Note that this function is only available if  Teamcenter (the OMF server) and CATIA 

are running on the same host. 

 

To Mark or Unmark Parts you can use the following actions: 

 

In the CATIA Workbench: in the Pop-Up menu of  parts and assemblies you can use 

the Mark/Unmark Part option. 

  

 

Use the standard selection mechanisms (lef t click, lef t click and [Shif t], lef t click and 

[Cntrl] to select several items, then choose Action > Mark Selected Items 

  

 
In the CATIA Workbench: Action > Marked Items > Unmark All 
All items are set to the unmarked state. 

  

 
In the CATIA Workbench: Query > CATIA-Item 

A Query-Dialog appears. Fill out the f ields of  the Query-Dialog to specify the parts 

and assemblies to f ind, as you are used to do in a standard Teamcenter Enterprise 

Query-Dialog. 

 

Use the Clear-Button to empty all input f ields. The Query will f ind and mark all parts 

and assemblies in the CATIA Workbench. 

 

Mark Items functionality also supported with CATIA V5. 

 

Set the active model 

Predef ine the model to be the ‘active model’ in the next CATIA Session in your CATIA 

Workbench.   

 

 
Start the CATIA Workbench as described in chapter 3. 

 

 

In CATIA: METAPHSE > READ  (conf irm with “yes”) 

 

 

CATIA goes into the background. The CATIA Workbench is automatically emptied 

and comes into the foreground. 

Drop one or more assemblies into your CATIA Workbench and expand the structure. 

 

 
To see the models in the CATIA Workbench you have to activate  

‘View > Display Models’ in your CATIA Workbench. 
 

 

Use the right mouse button to get the context menu and select ‘Activate Model’. The 

model is now displayed red. 
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Notice: 

It is only possible to activate models which are owned by you.  
Only one model can be the active model. 

 

 
Select ‘Action > To CATIA’. The content of  the CATIA Workbench is loaded in CATIA 

and the model displayed red is set the active model.  

 

 
If  no model is activated in your CATIA Workbench, CATIA activates the f irst model 
in the CATIA model list. 

 

 

Sending Parts to 4D-Navigator 

It is possible to send the content of  the CATIA Workbench to the 4D-Navigator. 

 
In CATIA Workbench, select menu Action > To 4D-Navigator 
The assembly is transferred to 4D-Navigator. 

 
In the CATIA Workbench, it is also possible to select menu Action > Marked Items > 
Marked To 4D-Navigator. On using this function, only the marked items are 

transferred to 4D-Navigator. 
  

 

Remember that the path to the 4D-Navigator exchange-map has to be set with: 

In CATIA Workbench: Options > Change Preferences > CMI Preferences 

 

 

DMU-Volume 

For a volume based DMU-Search you must create DMU-Volumes for CMI. 

 
In a Teamcenter Enterprise standard browser select Create > DMU Volume 

  

 

Notice: 

To evaluate the volume-search of  Catia-models, bounding boxes must be generated 
for all Catia-models, and the administrator has to set up the DMU-facilities by 

conf iguration-variables. The generation of  bounding boxes is specif ied with 
installation of  Catia. To verify  the bounding box values of  a Catia model, select Info 

> Get Item Info 
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Figure 43: The Create DMU Volume dialog 

A DMU-Volume is def ined by two x/y/z coordinates like a bounding box. The volume 
relates to a Root-Part, that means the same volume for a Child -Part must dif fer f rom the 

Root-Part corresponding to the transformation-matrix. 

 

Neighbourhood of  models 

 

Notice: 

To evaluate the neigbourhood of  Catia-models, bounding boxes must be generated 

for all Catia-models, and the administrator has to set up the DMU-facilities by 
conf iguration-variables. The generation of  bounding boxes is specif ied with 
installation of  Catia. To verify  the bounding box values of  a Catia model, select Info 

> Get Item Info 

 



 

54  CMI User Manual 

 

Figure 44: GetInfo CATIA Model dialog 

You can display all “neighbour-models” to a model in the workbench. 

 

 
In CATIA Workbench, select a root-assembly and select menu Action > Create DMU-
File. This assembly will be expanded down to all leafs and  a DMU-File is created with 
all absolute positions and the bounding-boxes of  all models. This f ile is stored in a 

DMU-Vault. 

 
Select the desired Catia model and select menu Action > Show Neighbourhood. The 
root-assembly is expanded down to the selected Catia model and to all “neighbour-

models” by evaluating the DMU-f ile. 

 
For several Catia models Select the desired Catia models and select menu Query > 
DMU > Show Neighbour s. The root-assembly is expanded down to the selected Catia 

model and to all “neighbour-models” by evaluating the DMU-f ile. 

  

 

Notice: 

You can af fect the computation of  neighbourhood by increasing the DMU-Tolerance. 

Increasing the DMU-Tolerance means increasing the bounding-box of  the selected 

model.  

In CATIA Workbench: Options > Change Preferences > DMU Preferences 

 

 

Volume search for  models 

You can display all models of  a predef ined volume in the workbench.  

 

 
In CATIA Workbench select menu Query > DMU > Show models of DMU-Volume. All 

models of  a volume will be expanded f rom a Root Part down to the leaf -parts. 

The menu item Query -> DMU -> “Show Models of  DMU-Volume” presents a Dialog-

window to ask for the Root part and for the DMU-Volume: 
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Figure 45: Select Root and Volume dialog 

If  you click the selection-box for the root Part, all Part Numbers and Revisions are shown 
for which a CMI-DMU-File exists. If  the root Part is determined, the click of  the Volume-

Name-selection-box shows all Volumes of   this specif ic root Part.  

If  there is no Volume of  your choice for the root Part, you can perform a dynamic Volume-

Search by specifying all volume-values in the dialog-window. 

With the OK-button, the Volume search starts, and all Catia-Models of  the selected 

Volume are presented in the Workbench under the same root Part. 

 

 
Only Catia-Models with bounding boxes are searched. 

Prior to the Volume-Search a CMI-DMU-File must be created for the root Part via 

the Workbench-Action -> “Create DMU-File”. 

Prior to the Volume-Search a DMU-Volume must be created for the root Part via 

Action -> “Create DMU-Volume”. 

 

 

Import a Scene File 

It is possible to load a scene f ile that has been written with the 4D-Navigator. As result all 

models that are described in the scene f ile will be marked in the CATIA Workbench. 

 

 
In CATIA Workbench, select menu Action > To 4D-Navigator 
The assembly is transferred to 4D-Navigator. 
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In the 4D-Navigator: Modify the scenario by using only the Show / NoShow –

toggle. Af ter that, save the scenario in a so-called Scene-f ile 

 
In the CATIA Workbench, select menu File > Import 4Dnav-File. Choose the f ile that 
has been written in the last step. All models that were set to Show in 4D -Navigator 

will be marked in the Workbench. 

  

 

Notice: The assembly has to be loaded with the Action > To 4D-Navigator to the 4D-

Navigator, and the contents of  the Workbench must not be changed until this task.  

 

 

Canceling Communication 

If  necessary, you can cancel the communication while the CATIA session is waiting for an 

assembly structure: 

 
In CATIA Workbench, select menu Action > Cancel To CATIA 

The communication is cancelled, the CATIA window becomes active.  

 

 

Support of Quantity 

In Teamcenter Enterprise the relation between part version and part master (Uses Part 
Masters) has an attribute Quantity. This attribute indicates how many instances of  a 

component are used by an assembly.  

E.g. if  a certain screw is used 100 times in an assembly, you would add a component for 
the screw to the assembly only once, but set the quantity to  100 to indicate that there are 

100 pieces of  these screws needed for the assembly. 

But you will not necessarily keep a CATIA model for the screw, and you don’t want to 
position each screw individually. Therefore with the default parts CMI ignores the quantity. 

Each part is transferred to CATIA only once, matching the visible product structure. 

To indicate that CMI should instead observe the quantity, you can create a special 
subassembly relation, the Uses Part Masters with Qty relation. Whenever this relation is 

used to build an assembly, the quantity will be observed in CMI. In the example each of  
the 100 screws would be represented in CATIA. Only one physical model exists, but you 

can position each screw individually using the CMI functionality.  
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Figure 46: How to create subassembly relations that support Quantity. 

The Uses Part Masters with Qty relation is created by dropping parts onto an Edit 

Relationship browser. 

 

Using a Multi-Quantity Relation the Quantity is limited to 100 instances by default. 

An administrator can change this limit. 

See CATIA Teamcenter Interface Customizing Guide for this and additional 

considerations regarding CMI Quantity support.  
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CHAPTER 7 

The CATIA V4 CMI Function 
This chapter describes how to use the CATIA function METAPHSE within the CATIA 

environment and its interaction with CMI and Teamcenter Enterprise.  

 

Menu structure in CATIA 

The following f igure shows the menu structure of  the CMI CATIA V4 module. In this 

structure it is possible to see which menu items can be reached through this CATIA 

function 

MOD STRU

CREATE

READ

TRANSLATE

ADD TMP

MOVE WP

REPLACE

DROP

REREAD

ROTATE

MOVE

SET

DOWN

UP
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LINE
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DOCUMENT
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DEFAULT

ASSEMBLY
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INFO
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REUSE

STORE

RESYNC

MUL CRE

 

Figure 47: CMI CATIA function menu structure 
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Usage of the CATIA CMI function 

The METAPHSE function is designed conformab ly to the look and feel of  the CATIA Motif  

user interface. If  you are familiar with the CATIA user interface, you will be able to work 

with the METAPHSE function just as well as usual.  

If  any message appears on the status line, you can type  

/help 

on the CATIA command line to get more information about this message. 

To get help for the active menu point, you can type 

/edmhelp. 

 

METAPHSE->READ 

This menu item reads CATIA models, CATIA documents and CATIA parts and assemblies 

placed in the CATIA Workbench. 

If  you want to send one or more assemblies or models use: 

 

Read Teamcenter CATIA items with METAPHSE > READ 

 
Af ter your conf irmation Teamcenter comes up. 

 

 
Drag and drop parts, assemblies, documents or models into the Workbench.  

Expand or Deexpand the assemblies or models in the workbench. 

Send it to CATIA with Action > To CATIA 

  

 

Modify your CATIA model 

Write the modif ications back with METAPHSE > UPDATE > ALL 

 
Af ter your conf irmation the geometry and position information will be updated in 

Teamcenter Enterprise. 

 

 
You’ve loaded a Teamcenter Enterprise ‘document’ with n CATIA models and want 

to modify one of  these CATIA models? 

You can switch to any CATIA model in memory and modify it. Af ter you’ve f inished, 

write the modif ications back with METAPHSE > UPDATE > ACTIVE (see also 
chapter ‘Switching the active model’) 
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METAPHSE > UPDATE 

The menu item ‘UPDATE’ contains actions to update geometry and position information in 

Teamcenter Enterprise. 

UPDATE > ALL  

This menu item updates all geometry and position information in the Teamcenter 
Enterprise database. All items must have been loaded f rom your Teamcenter Enterprise 

system before. 

 

 

Read Teamcenter Enterprise CATIA items with METAPHSE > READ 

Modify the geometry or position information 

Write the modif ications back with METAPHSE > UPDATE > ALL 

 
Af ter your conf irmation a list of  models that have been modif ied will come up in 

CATIA. If  some models were active, but the user must not change these models, a 

status panel will pop up. It is not necessary to conf irm this panel.  

Select the models you want to update. 

The selected models will be updated in Teamcenter Enterprise.  

 

 

Figure 48: Dialog for Update CATIA Models 

UPDATE > ACTIVE 

This menu item updates the geometry information of  the active model in CATIA in the 
Teamcenter Enterprise database. As a prerequisite the model must have been loaded 

f rom your Teamcenter Enterprise system before. 

 

 

Read Teamcenter Enterprise CATIA items with METAPHSE > READ 

Modify the geometry information 

Write the modif ications back with METAPHSE > UPDATE > ACTIVE 

 
Af ter your conf irmation the geometry information of  the active model in CATIA will be 

updated in Teamcenter Enterprise. 

 

This menu item can also be used to update the following models: 

➢ Models which have been loaded as a part of  an assembly structure, 
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➢ Models which have been loaded as a part of  a Teamcenter ‘Document’ that 

contains more than one CATIA model. 
 

UPDATE > POSITION 

This menu item updates all position inf ormation changed in CATIA in the Teamcenter 

Enterprise database. As a prerequisite the assembly must have been loaded f rom your 

Teamcenter Enterprise system before. 
 

 

Read Teamcenter Enterprise CATIA items with METAPHSE > READ 

Modify the position information 

Write the modif ications back with METAPHSE > UPDATE > POSITION 

 
Af ter your conf irmation all position information changed will be updated in 

Teamcenter Enterprise. 
 

 
To modify the position information between two parts you have to use the 

METAPHSE > ASSEMBLY > MOD POS command in CATIA. Please refer to chapter 
‘The Workplane‘ to see how to use the workplane concept. 

 

UPDATE > GEOMETRY/MODELS 

This menu item updates the geometry information of  all activated models in CATIA in the 
Teamcenter Enterprise database. As a prerequisite the models must have been loaded 

f rom your Teamcenter Enterprise system before. 
 

 

Read Teamcenter Enterprise CATIA items with METAPHSE > READ 

Modify the geometry information 

Write the modif ications back with METAPHSE > UPDATE > GEOMETRY 

 
Af ter your conf irmation a list of  models that have been modif ied will come up in 
CATIA. If  some models were active, but the user must not change these models, a 

status panel will pop up. It is not necessary to conf irm this panel. 

Select the models you want to update. 

The selected models will be updated in Teamcenter Enterprise.  

 

 

Figure 49: Dialog for Update CATIA Models 
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METAPHSE > DOCUMENT 

The menu item ‘DOCUMENT’ contains actions to save the active model in CATIA in the 

Teamcenter Enterprise environment. 

DOCUMENT  > SAVE AS 

This menu item creates a Teamcenter Enterprise ‘CATIA model’ object f rom the model 
that is currently active in CATIA. A CATIA model selected in Teamcenter Enterprise and 

dropped into the Workbench is then overwritten by the contents of  the CATIA model in 
CATIA-memory. (Please refer to Chapter 6 for more information how to create a ‘CATIA 

model’ object in Teamcenter Enterprise).  

 

 

Design or load your local CATIA model 

In CATIA select METAPHSE > DOCUMENT > SAVE AS 

  

 

Double click or drag the Teamcenter Enterprise CATIA model object that you want to 

create into the workbench. Its contents will be overwritten with the model that is 

active in CATIA. 

 

 
Notice: 

If  the model you save was opened with File->Open in CATIA, it will be replaced by 
the model you dropped. 
If  the model you save came f rom Teamcenter Enterprise the model you dropped 

will be added to the CATIA Session and made the active model.  
So in both cases you can continue to work with the model and later update it in 
Teamcenter Enterprise.The content of  the CATIA Workbench is not cleared.  

 

DOCUMENT  > CREATE 

This menu item creates a Teamcenter Enterprise ‘CATIA model’ object f rom the model 

that is currently active in CATIA. A Teamcenter dialog window appears and you can enter 

additional attributes. 

 

Design or load your local CATIA model 

In CATIA select METAPHSE > DOCUMENT > CREATE 

  

 
A Teamcenter Enterprise dialog window appears. 

Fill out the f ields and press ‘OK’ 

A new model will be created in the Teamcenter Enterprise environment.  

 

 
Notice: 
If  the active f ile was opened with File->Open in CATIA, it will be replaced by the 
new model registered in Teamcenter Enterprise. 

If  the active model came f rom Teamcenter Enterprise the new model will be added 
to the CATIA Session and made the active model.  
So in both cases you can continue to work with the model and later update it in 

Teamcenter Enterprise. The content of  the CATIA Workbench is not cleared.  
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DOCUMENT  > MUL CRE (multi create) 

This menu item creates multiple Teamcenter Enterprise ‘CATIA model’ objects f rom the 

CATIA Session. The new CATIA models are assigned to one ‘DOCUMENT’. For each 
model a Teamcenter Enterprise dialog window appears and you can enter additional 

attributes. 

It is recommended to use this functionality to import supplier CATIA Sessions / models 
into the Teamcenter Enterprise database. So only models loaded by native CATIA 

FILE/SESSION OPEN, will be of fered to be created.  
 

 

Load several models f rom a native CATIA MAP  

METAPHSE > DOCUMENT > MUL CRE 

 Select the models to be created in Teamcenter Enterprise 

 

Notice: 
If  the active model was opened with File ->Open in CATIA, it will be pre selected 

 CREATE to conf irm 

 
Drop a DOCUMENT into the CATIA Workbench 

For each model a Teamcenter Enterprise dialog window appears.  

Fill out the f ields and press ‘OK’  

A new model will be created in the Teamcenter Enterprise environment. 
 

 
Notice: 
The models registered in Teamcenter Enterprise will be replaced in CATIA by the 

new Teamcenter Enterprise models.  

 

 

Figure 50: Dialog for Multi Create Models in CATIA 

 

Figure 51: Dialog for Multi Create Models in Teamcenter. 
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DOCUMENT > HL IN WB 

This menu item marks the selected model in the CATIA Workbench. This provides a link 

back f rom CATIA to Teamcenter Enterprise. 

Models must be displayed in the Workbench to see the ef fects of  this function.  

 

Choose DOCUMENT > HL IN WB 

Select the model you want to mark in Teamcenter Enterprise 

 
Af ter your conf irmation the model will be marked in the CATIA Workbench. See 

Chapter 7: Working with marked Parts 

DOCUMENT > INFO 

This menu item gives you information, stored in Teamcenter Enterprise, about parts you 

will select.  

 

Choose DOCUMENT > INFO 

Select the model f rom which you want to have information. 

 

Figure 52: Model Info dialog 

After pressing ‘Cancel’ you can select other parts to get their information.  

 

METAPHSE > REREAD 

This menu item reads CATIA models, CATIA documents and CATIA parts and assemblies 

placed in the CATIA Workbench. 

It works the same way as the METAPHSE > READ function, but in dif ference to it all 

functions do not delete the current CATIA Session. All METAPHSE > REREAD functions 
leave non-CMI models unchanged. This means the designer is able to use 
models/assemblies f rom CMI in conjunction with other models, e.g. models loaded over 

the CATIA File Open… function. 

This function is also valuable in cases where you want to expand the assembly already 
loaded into the CATIA Workbench in a dif ferent way (e.g. de-expand one sub tree and re-

expand another one instead). It is also possible to add new CATIA models, CATIA 
documents and CATIA parts and assemblies to the Workbench. Af ter having reread the 
modif ied contents of  the CATIA Workbench, CATIA will ref lect the new situation shown in 

the Workbench. 

Generally all METAPHSE > REREAD functions are much faster than the METAPHSE > 
READ because only your current CATIA Session is only updated with the parts of  the 

Workbench content not yet loaded to CATIA. 
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REREAD > ALL 

All unsaved modif ications (positions and geometries) will be updated with the original data 

f rom CMI. REREAD->ALL leaves non-CMI models untouched in the session. 

REREAD > GEOMETRY 

REREAD->GEOMETRY updates the current CATIA Session with the CMI Workbench 
content. In addition REREAD->GEOMETRY resets all changed and unsaved models to its 

original condition. REREAD->GEOMETRY leaves modif ied positions untouched.  

REREAD->GEOMETRY leaves non-CMI models untouched in the session. 

REREAD > POSITION 

REREAD->POSITION updates the current CATIA session with the CMI workbench 
content. REREAD->POSITION resets all changed and unsaved positions. REREAD-

>POSITION leaves modif ied geometries untouched.  

REREAD->POSITION leaves non-CMI models untouched in the session. 

REREAD > RESYNC 

REREAD->RESYNC updates the current CATIA session with the CMI Workbench 

content. Only models which are not already loaded in CATIA will be added to the current 
CATIA session. In dif ference to REREAD->ALL REREAD->RESYNC leaves your modif ied 

models and positions unchanged in your session. 

 This is the fastest way to synchronize the contents of  CATIA with the workbench.  

REREAD->RESYNC leaves non-CMI models untouched in the CATIA Session. 
 

 

Choose the appropriate METAPHSE > REREAD > .... in CATIA. 

 
Af ter your conf irmation Teamcenter Enterprise comes up. 

 

Drag and drop parts, assemblies, documents or models into the Workbench if  you 
want to add new ones, and/or Expand or Deexpand assemblies or models in the 

workbench. Send it to CATIA with ACTION > To CATIA 

 

 

Introduction to the Assembly Structure 

Switching the active model 

By switching the active model all individual parts in an assembly can be worked on. 

Switching will only work on parts belonging to the user. 
 

 

MODEL > SWAP :Swapping the active model (standard CATIA function) 

Select a model 

 
CONFIRM with YES 

 

Edit model 

Write back the modif ications with: 

METAPHSE > UPDATE > ACTIVE 

 
CONFIRM with YES 

 

 
 You can f ind out the loaded and the active models by help of  the standard CATIA 
function: SESSION > MANAGE 
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METAPHSE > ASSEMBLY 

The menu item ‘ASSEMBLY’ contains assembly structure relevant actions.  

ASSEMBLY > MOD STRU 

This menu item (Modify Structure) with its sub items allows you to modify the assembly 
product structure in Teamcenter Enterprise f rom CATIA. The following functions suppose 

that an assembly is loaded into the CATIA memory: 

ASSEMBLY > MOD STRU > DROP 

This menu item removes the relationship between selected sub part and assembly. 

 

Read assembly as described in chapter ‘METAPHSE->READ’ 

Choose 

ASSEMBLY > MOD STRU > DROP 

Select a sub part (the selected part will be highlighted) 

You can also pick the part to set the subassembly to drop. Click YES instead of  

selecting a model: 

 

Figure 53: Panel for Select a Subassembly to Drop 

 
Af ter conf irmation the sub part will disappear in CATIA memory.  

 

A panel asks if  you want to drop the subassembly in Teamcenter Enterprise also. If  

you click yes the relationship will be dropped in the actual Teamcenter product 

structure. 

 

 

Figure 54: Confirm Drop in EDM dialog 
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CAUTION: 
The relationship is also dropped in the Teamcenter product structure. 

ASSEMBLY > MOD STRU > REPLACE 

This menu item replaces the selected sub part by another one. 

 

Read assembly as described in chapter ‘METAPHSE->READ’ 

Choose 

MOD STRU > REPLACE 

Select a subassembly (the selected part will be highlighted) 

 
Af ter conf irmation the CATIA Workbench window comes to the foreground. 

 

Drop the Part you want to replace the subassembly with into the CATIA Workbench. 
The Workbench will show the new part in place of  the old one. Click Action > To 

CATIA 

 

CATIA comes to the foreground and the selected part is replaced by the new one. 

 

 
CAUTION: 
The relationship between two parts is also replaced in the Teamcenter Enterprise 

product structure. 

ASSEMBLY > MOD STRU > ADD TMP 

Allows the user to visualize a temporary structure together with the working one. 

For example, if  the user is making a design of  a car and wants to see if  the luggage 
compartment is big enough, he can load a suitcase as a temporary structure by doing the 

following (supposing that the car structure is already loaded): 

 

 

Read the whole assembly as described in chapter ‘METAPHSE->READ’ 

Choose 

MOD STRU > ADD TMP  

 
Af ter conf irmation the CATIA Workbench window comes to the foreground.  

 

 

Drop the assembly or model you want to add into the CATIA Workbench. Expand it 

as necessary. Click Action > To CATIA in the Workbench menu. Changes you make 

to other assembly structures in the Workbench will not be sent to CATIA at this time.  

 

 

CATIA comes to the foreground with both the car and the suitcase structure. In this 
case, it is not possible to carry out any changes in the suitcase structure. 
The temporary added part is removed f rom the CATIA Workbench af ter you send it 

to CATIA. 

ASSEMBLY > MOD STRU > MOVE WP 

The work plane def ines the level in a sub tree of  a hierarchical assembly relative to which 
modif ications in the hierarchical assembly become ef fective. The relative location and 
rotation between a part and one of  its sub-parts or sub-structures is def ined by a 

relationship. If  there is only one tree structure, then the f irst Part of  the tree becomes the 
root. If  there are several trees or other models in CATIA, then a virtual root joins the 

independent models and sub-trees to one tree.  
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Part

Relation

Root

 

Figure 55: Tree-structure with one tree 

 

 

Part

Relation

Virtual

Root

 

Figure 56: Tree-structure with several trees and a virtual root 

 

It is only possible to transform the relationships between the active work plane and its 

direct sub-parts and its sub-structures. 
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Part

Relation

Active Workplane

Changeable Relations
 

 

Figure 57: Active workplane in the tree structure 

 

 
The active work plane and the active model are dif ferent. If  you want to edit a model 

you have to make it active.  

If  you move or rotate a model in the structure by using the TRANSFOR Function 
then you do not change the relationship to the root structure element, but the 

geometry of  the active model. 

 

There are several possibilities to choose the active wo rk plane: 

ASSEMBLY>MODSTRU>MOVE WP > IN WORKB 

Call the active work plane f rom the workbench 

 

 
CONFIRM with YES 

 

Choose the assembly in the CATIA-workbench with the right mouse button 

Set work plane (see f ig. Below) 

Send the active work plane from the Workbench to CATIA 

 

Choose the assembly in the CATIA-workbench with the right mouse button 

Set work plane 
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Figure 58: Choose the active workplane in the CATIA Workbench 

ASSEMBLY>MODSTRU>MOVE WP > UP 

 
CONFIRM with YES 

Moving the Workplane up means that the Workplane will be a part in a higher layer of  the 
structure, see in the f igure below. The models below the active workplane are highlighted. 

If  there is no higher layer a message will be displayed.   

1. 
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Figure 59: Moving the Workplane ‘up’. 

ASSEMBLY>MODSTRU>MOVE WP > DOWN 

Moving the workplane down means that the active workplane crosses the tree-structure 
downwards, see in the f igure below. The models below the active workplane are 

highlighted. If  there is no lower workplane a message will be displayed.  

 

 
CONFIRM with YES 
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Figure 60: Moving the Workplane ‘down’. 

ASSEMBLY>MODSTRU>MOVE WP > SET 

Select Element:  

The active workplane and its sub-trees are highlighted.  

Or 

 
CONFIRM with YES 

 

Choose the new workplane f rom the list (the chosen part and its sub -trees is highlighted) 

and conf irm with OK. 

 

Figure 61: Selection panel for the new workplane 

ASSEMBLY > MOD POS 

This menu item (Modify Position) with its sub items allows you to modify the positioning of  

the assembly product structure in Teamcenter f rom CATIA. The following functions 

suppose that an assembly is loaded into the CATIA memory: 

With all operations in this menu you can use the CATIA YES-button to get a list of  all 

models below the current workplane. So it is easy to select the part you want to move.  
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Figure 62: Model selection panel 

Please use the ‘Filter On Model’ f ield to f ind only some specif ic models.  

ASSEMBLY > MOD POS > TRANSLAT  

This menu item (Translate) translates the selected part in the direction indicated by the 

selected line, axis or f rom point to point. 

 

 

Read an assembly as described in chapter ‘METAPHSE->READ’ 

Select workplane as described in chapter ‘ ASSEMBLY > MOD STRU>MOVE WP’ 

Select: MOD POS > TRANSLAT 

Select a part in a sub-tree of  the actual workplane (the selected tree will be 

highlighted red). 

 Select a vector or line (the selected line/vector will be highlighted red). You can also 
select a f irst and second point (a red highlighted vector between the 2 points will be 

created). 

 Enter a distance or select the second point. 

 Click at the vector or press the ENTER Button in order to change the transformation 

direction. 

 
Conf irm with YES. 

The selected part will be translated. 

 

ASSEMBLY > MOD POS > ROTATE 

This menu item rotates the selected part around an axis.  

 

 

Read an assembly as described in ‘METAPHSE->READ’ 

Select workplane as described in chapter ASSEMBLY > MOD STRU>MOVE WP’ 

Select: MOD POS > ROTATE 

Select a part in a sub-tree of  the actual workplane (the selected tree will be 
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highlighted red). 

 Select an vector/line (the selected vector/line will be highlighted red). In addition a 

rotation angle occurs to visualize the rotation direction.  

 Enter an angle or  

Select a point/line/plane and a 2nd point/line/plane. 

A rotation angle will be calculated and displayed. 

 
Conf irm with YES. 

The selected part will be rotated. 

 

ASSEMBLY > MOD POS > MOVE > AXIS 

This menu item moves the selected part f rom one coordinate system to another one.  

 

 

 

 

 

 

 

Read an assembly as described in chapter ‘METAPHSE->READ’ 

Select workplane as described in chapter ‘ ASSEMBLY > MOD STRU >MOVE WP’ 

Select: 

MOD POS > MOVE > AXIS  

Select a part in a sub-tree of  the actual workplane (the selected tree will be red 

highlighted) 

Or 

 
Conf irm with YES 

Select part in list 

 Select f irst axis  

or  

create your axis by:  

Select a point to create the base 

Select another point, line, plane to create the x-axis (change direction by ENTER) 

Select another point, line or plane to create the y-axis (change direction by ENTER) 

Conf irm with YES to create the z-axis 

 Select second axis  

or  

create your axis by:  

Select a point to create the base 

Select another point, line or plane to create the x-axis (change direction by ENTER) 

Select another point, line or plane to create the y-axis (change direction by ENTER) 

Conf irm with YES to create the z-axis 

 Click at the vector or press the ENTER Button in order to change the transformation 

direction. 

 
Conf irm with YES. 

The selected part will be moved to the second coordinate system.  
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ASSEMBLY > MOD POS > MOVE > SYMMETRY 

This menu item mirrors the selected part in relation to a 2D plane. 

 

 

Read an assembly as described in ‘METAPHSE->READ’ 

Select workplane as described in chapter ‘ ASSEMBLY > MOD STRU >MOVE WP’ 

Select: 

MOD POS > MOVE > SYMMETRY  

Select a part in a sub-tree of  the actual workplane (the selected tree will be 

highlighted red). 

 Select a plane (the selected plane will be highlighted red).  

 
Conf irm with YES. 

The selected part will be mirrored. 

 

ASSEMBLY > MOD POS > MOVE > LINE 

This menu item moves a part. The relative position between the f irst selected line and the 

selected part is identical to the relative position between the second selected line and the 

part af ter the action is completed. 

 

 

Read an assembly as described in ‘METAPHSE->READ’ 

Select workplane as described in chapter ‘ ASSEMBLY > MOD STRU >MOVE WP’ 

Select: 

MOD POS > MOVE > LINE  

Select a part in a sub-tree of  the actual workplane (the selected tree will be 

highlighted red). 

 Select the f irst and second line (the selected lines will be highlighted red).  

 
Conf irm with YES. 

The selected part will be moved. 

 

ASSEMBLY > MOD POS > TRAFO   

The TRAFO functionality is to facilitate the work with all transformation routines of  the 

CMI CATIA module. 
This function gives the user the ability to reuse a transformation once def ined multiple 
times. To work with this function at least one transformation must have been performed 

before. 

ASSEMBLY > MOD POS > TRAFO  > STORE 

This menu item stores the last transformation done (ASSEMBLY > MOD POS> 

TRANSLATE / ROTATE / MOVE). The stored transformation can be used on any other 

part (TRAFO > REUSE).  

 

Change the position of  an assembly: METAPHSE > ASSEMBLY > MOD POS > ... 

Select: 

MOD POS > TRAFO > STORE 

 
Conf irm with YES. 

The last transformation part will be stored. 
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ASSEMBLY > MOD POS > TRAFO  > REUSE 

After you have stored a transformation, you can reuse it on any part you want. This menu 

item reuses the last stored transformation.  

 

Select work plane as described in chapter ‘ ASSEMBLY > MOD STRU >MOVE WP’ 

Select a part in a sub-tree of  the actual workplane (the selected tree will be 

highlighted red). 

Select: 

MOD POS > TRAFO > REUSE 

 
Conf irm with YES. 

The last transformation part will be reused on the highlighted part.  

 

PLOT 

The menu item ‘PLOT’ attaches the created plot f ile to the active document object in 

Teamcenter Enterprise. 

 

 

Read a Teamcenter ‘CATIA Model’ object with: 

METAPHSE > READ 

Design your view which you want to plot 

Select: METAPHSE>PLOT 

 
Af ter conf irmation the plot f ile is generated. 

 Save the document back with: 

METAPHSE > UPDATE > ACTIVE 

 
Af ter conf irmation the generated plot f ile is registered within Teamcenter Enterprise 

and attached to the Teamcenter Enterprise CATIA Model object.  

 

 

Menu structure in CATIA 

With the menu item ‘DEFAULT’ you can switch the work plane functionality. The work 

plane concept is described in ASSEMBLY > MOD STRU > MOVE WP.  

 
If  you do geometry transformations with the ASSEMBLY > MOD POS > ... function 

then it is necessary to have the right work plane active  

This panel allows you to select the way in which the work plane is activated.  

 

The default selection of  the panel is Assembly. 
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Figure 63: Default panel 

Geometry 

 If  you check ‘Geometry’, the ASSEMBLY > MOD POS functions will change the position 
of  the selected geometry (Model) instead of  the assembly. This option is only available if  

Geometry positions are supported in your customization of  CMI.  

 Default Workplane 

If  ‘Default Workplane’ is checked the work plane is automatically set to the next higher 

assembly in the assembly tree when you select a model.  

 

Automaticly set Workplane 

Changeable  Relation 

Selected  Element 

 

Figure 64: Automatically set default work plane 

 Assembly 

 If  you check ‘Assembly’ you can set the work plane with the ASSEMBLY > MOD STRU > 
MOVE WP commands. If  you switch ASSEMBLY > MOD STRU > MOVE WP or set the 

work plane f rom the CATIA - workbench, the selection is automatic reset to assembly. 

Multiselection 

Check Multiselection to apply ASSEMBLY > MOD POS positioning to multiple parts at 
once. The parts to be positioned can be selected in a panel.  
Note that only the leaves of  an assembly are disp layed for selection. Also a part that 

occurs in the assembly both as a leaf  and with subassemblies is not displayed for 

selection. 
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To-do: 

 

Check METAPHSE > DEFAULT: Multiselection 

METAPHSE > ASSEMBLY > MOD POS > ... 

 
Conf irm to get a list of  the selectable elements 

 

Select the elements to be transformed (The selected elements are highlighted red) 

and conf irm with OK.  

 

Do the transformation as described in METAPHSE > ASSEMBLY > MOD POS > ... 

 

 

Menu structure in CATIA 

To get help for CMI you have 2 possibilities: 

Click on METAPHSE->HELP and the browser, which was specif ied in the customization, 

will appear in order to show the complete CMI user manual.  

To get help for a specif ic menu point of  the CMI CATIA module do the following: 

Activate the menu point for which you want to get the help. 

Select in the Help Drop Down menu ‘CMI Context Help’ 

The browser, which was specif ied in the customization, will appear in order to show the 

Help chapter for the active menu point. 

 

 

Figure 65: CMI Context Help 

Please refer to the installation guide how to customize your default help viewer launching.  

 

The Messages in CATIA 

In addition to the online help, it is also possible to get more information to the messages 

inside the CATIA session on the CATIA command line as following: 

/help 
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This is the list of  message numbers and their meaning  

Numb
er 

Panel output Description 

20501 MODEL LOAD OK  Your model has been loaded successfully. 

20502 MODEL SAVE FINISHED  Your model has been saved successfully.   

20503 MODEL UPDATE FINISHED  Your model has been updated successfully.   

20504 LOAD OK  Your assembly is now loaded. 

20505 TEMPORARY ASSEMBLY LOAD OK  Your assembly is now loaded temporary. 

20506 ASSEMBLY UPDATE FINISHED  Your assembly has been successfully updated. 

20507 ASSEMBLY DROP FINISHED  Your DROP action has been successfully 
f inished. 

20508 NO MODEL HAS BEEN CHANGED  No model or assembly has been changed since 
loading. 

20509 MODEL IS ALREADY IN MAP  The model you want to create is already in 

exchange map. So a overwriting would be 
performed and could cause lost of  model data. 

20510 NO POSITION HAS BEEN CHANGED No position has been changed since loading. 

20600 INIT PDM MODULE  This is just a hint that the init process was 
started 

20605 INIT OK  This is just a hint that the init process was ok 

20606 REQUEST REFUSED  The request was refused because an EDM 

process is always pending. Please end the 
current action and try again. 

20610 CAN NOT ALLOCATE PANELFILES  The panel f iles can not be found, please consult 

your CATIA system administrator 
20615 ERROR IN PERSONAL 

ENVIRONMENT SCRIPT  
Your private environment settings script is 
corrupt.  Please contact your system 

administrator. 
20616 ERROR IN GENERAL ENVIRONMENT 

SCRIPT  
The general environment settings script is 
corrupt.  Please contact your system 

administrator. 
20620 FAILED TO OPEN THE LOGFILE  You have specif ied a log f ile in your setting. This 

log f ile cannot be opened. 

20625 TEMPORARY PART  You have selected a temporary part, which 
cannot be transformed in its position. 

20626 TEMPORARY MODEL  Your active model is a part of  a temporary 

added document.  Such models can't be created 
or updated.  Please swap back to the model 
loaded active if  you wish to save it. 

20630 NO ASSEMBLY  You have selected a normal model that isn't a 
part of  an assembly. 

20631 DROP ERROR  An error occurred while you tried to drop a 

model.  This may happen, if  a drop to an active 
model was performed.  To f ix it, please change 
your work plane before DROP. 

20632 NO ASSEMBLY LOADED  Only one model is loaded! 

20633 NO MODEL LOADED  No model was loaded to perform this action. 

20634 SYMMETRY NOT ALLOWED Symmetry is allowed only for geometry position 
changing. 
Change the current working mode to geometry. 

20635 ACTIVE MODEL WRONG  The active model is inside of  the subassembly 
selected for modif ication, Please swap to a 
model outside of  this subassembly. 

20636 ALL MODELS IN READ ONLY 
ACCESS  

Your active model is a temporary empty model; 
it is only used internally. Please swap to the 
model your selected action is related to. 

20637 ACTIVE MODEL WRONG  You tried to replace an assembly outside of  your 
work plane.  Please change your work plane. 

20638 NO MODEL SELECTED  No model was selected.  Please change your 

work plane. 
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20639 ACTIVE MODEL HAS NO FRAME  Your currently selected active model is not your 

f irst model below the root. Only the f irst root 
model contains valid drawing f rame attributes! 
No plot sheet will be generated. 

20640 MODELNAME IS MISSING  You tried to save a model without a title.  Please 
setup a title for this model. 

20641 SOME MODEL(S) ARE NOT 

READABLE  

CATIA was unable to read the following 

model(s): 
20642 FAILED TO RENAME MODEL  The model RENAME function failed probably 

because of  problems with your exchange map. 

20643 MODEL IS NOT READABLE  CATIA was unable to read the model C01 
located in C02 

20644 FAILED TO SAVE MODEL  CATIA cannot save the active model in the PDM 

system.  Check your access rights of  this model 
in the PDM system. 

20645 FAILED TO UPDATE MODEL  CATIA cannot update the active model in the 

PDM system. 
20646 FAILED TO LOAD MODEL  CATIA cannot load the specif ied model. 

20648 MODEL UPDATE NOT POSSIBLE  You can't update a model that isn't loaded f rom 
PDM system. Please use CREATE to insert the 
model in PDM. 

20650 NO CORRECT MODEL FOUND  CATIA cannot handle this model in the PDM 
system. 

20653 NO WRITE ACCESS TO MODEL  You tried to write a model in read only mode.  

You are not the owner of  this model. 
20654 NO ROOT MODEL  The assembly you have loaded has no root or 

an empty root. 

20655 INCORRECT ASSEMBLY  Something is wrong with your assembly. 

20656 MODIFICATION NOT ALOWED  It isn't allowed to modify the selected model; this 

model is a part of  root.  
20760 ACTION CANCELED  The action performed was canceled by EDM 

system. 

20761 MODEL HAS WRONG PROJECT  Some Models have incompatible project 
environment settings to your CATIA project.  
Check your project environment. 

20762 ASSEMBLY PARTIALLY UPDATED  Your assembly has been successfully updated, 
For more information refer your EDM system. 

20763 MODEL PARTIALLY UPDATED  Some models of  the splitted document couldn't 

be updated. 
20764 COMMUNICATION FAILED  Is your workbench open and initialized? 

20765 ACTION FAILED  The action performed was ended with an error. 

20800 PANEL ERROR  The panel function failed, check if  the desired 
panel def inition exists in the panel install 

directory. 
20801 NO INFO RETURNED  No info available for this model 

20810 NO VALID PLOT FORMAT ERROR  The ditto in current view isn't holding a valid plot 
format.  Please check the ditto. 

20811 PLOT FINISHED  The plot is f inished. 

20812 PLOT IN PROGRESS  The plot is in progress. 

20900 PLOT FORMAT TYPE ERROR  The selected plot format is invalid. 

20910 CANNOT MOVE WORKPLANE  The work plane can't be moved in this direction.  

The deepest or highest level in assembly 
structure has been reached. 

20911 FAILED TO CHANGE WORKPLANE  No valid document found to set the WP. 

20920 MODEL IN EXCHANGE MAP ALWAYS 
EXISTS  

A model with such a name always exists in your 
exchange map. Please rename your model or 
check in the model in your exchange map f irst 

and retry. 
20921 NO MODEL HAS BEEN LOADED  Before something can be added temporary, a 

model must be loaded with the read function. 
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20922 WARNING: MAP NOT FOUND IN 

DECL SERIES  

The map path searched for is not def ined yet in 

your declaration series. A new map will be 
created temporary. 

20923 NO MAP NAME FOR EXCHANGE MAP 

FOUND 

There is no MAP entry in your environment.  

Please contact your system administrator. 
20924 NO VALID MAP PATH OR DLNAME 

FOUND  
Couldn't f ind a valid entry in declaration series 
For the given search criteria.  Maybe the map 

you want to read f rom is invalid Please consult 
your CATIA system administrator. 

20930 SAME POINT SELECTED  Please select 3 dif ferent points.  

20931 WRONG VECTOR SELECTED  Please select the transformation vector to 
change the direction of  current transformation.   

20932 SAME AXIS SELECTED  Please select 2 dif ferent axes. 

20940 SELECTED MODEL IS NOT IN 

ASSEMBLY  

The selected model belongs not to an assembly 

loaded, so it can't be managed here.  Please 
use the standard CATIA functions 

20941 EXCHANNG MAP PATH DOES NOT 

EXIST  

The specif ied exchange map does not exist 

Please contact your system administrator. 
20942 CHANGES TO RO MODELS NOT 

ALLOWED  
Update a read only model. 

20943 MODEL DOES NOT EXIST  The model does not further exist in CATIA 
memory.  The model was deleted. 

20944 MODEL WRITE WAS NOT 

SUCCESSFULL  

The model could not be correctly written to Map.  

Maybe disk storage is low or NFS is poor.  
Please contact your system administrator. 

20950 WARNING: CHANGES IN SUBASS  There are changes in the subassembly selected 

for DROP. All model and relation changes have 
been made in this subassembly will be lost if  you 
continue.  If  you are unsure save the assembly 

before DROP. No model or assembly to update.  
The structure you have loaded contains no 
model. 

20960 NOTHING TO SAVE/UPDATE No model or assembly to update. 
The structure you have loaded contains no 
model. 

20965 NO TRANSFORMATION STORED Before you are able to use this function you 
have to store the last transformation you have 
done. 

20966 NO VALID TRANSFORMATION 
FOUND 

Unable to found a valid transformation for reuse. 
First a position must be changed, to be able to 
store a transformation. 

20967 NO TRANSFORMATION DONE YET First a position must be changed, to be able to 
store a transformation. 

20970 NO HELP SYSTEM DEFINED  A help system (Netscape or mosaic) must be 

def ined.  Please contact your system 
administrator. 

20971 CAN NOT CONNECT TO HELP 

SYSTEM  

Problems to connect to help system.  Please 

contact your system administrator. 
20972 NO HELP FILE FOUND  No or a wrong help f ile path was def ined in your 

environment.  Please contact your system 

administrator. 
20973 MODEL IS NOT PART OF 

WORKPLANE  
The model you've tried to change is not a part of  
a subassembly def ined by the work plane.  

Please reset your work plane. 
20974 FAILED TO READ STORAGE  Failed to read session data f rom application 

data.  Please contact your system administrator.  

20975 MODEL NEED TO BE WRITTEN  Before you can add a new model to an 
assembly you have to save this model on f ile 
system. 

20976 CATIA SESSION HAS BEEN 
CHANGED 

Current CATIA session has been changed. 
Please redo your selections. 
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20980 NO LICENSE NUMBER SET  No license number is set in environment.  

Please contact your system administrator. 
20981 LICENSE INIT FAILED  Could not init license process.  Please contact 

your system administrator. 

20982 NO MORE FREE LICENSES  All available licenses are currently in use.  Retry 
later or contact your system administrator. 

20983 LICENSE EXPIRED  Your license has been expired.  Please contact 

your system administrator. 
20984 NO LICENSE FOR MODULE  No license installed for this module.  Please 

contact your system administrator. 

20985 DIFFERENT MACHINE TIMES  The LLD machine time dif fers f rom the GLD 
machine time.  Please contact your system 
administrator. 

20986 NO CONNECTION TO LLD  No connection to local license daemon.  Please 
contact your system administrator. 

20987 NO CONNECTION TO GLD  No connection to global license daemon.  

Please contact your system administrator. 
20988 UNKNOWN LICENSE ERROR  Something is wrong with your license 

environment.  Please contact your system 

administrator. 
20989 UNABLE TO START LLD Please check your license environment or 

contact your system administrator. 

20990 NO MODEL SELECTED  No model was selected. 

20991 NO MODEL FOUND  No model found. 

20992 NO POINT SELECTED  No point was selected. 

20993 SAME POINT SELECTED  Please select 3 dif ferent points. 

20994 POINTS ARE LYING ON ONE LINE  Please select at least one dif ferent point. 

20995 POINTS ARE IDENTICAL  Distance between two points is too small. 

20996 INVALID ANGLE VALUE  Input angle is less than angular tolerance.  

Invalid value for def ining rotation. 
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CHAPTER 8 

Working with CATIA V5 

 

Introduction 

This chapter describes the CMI interface between CATIA V5 and Teamcenter Enterprise. 
It provides you with a short overview of  the object structure in Teamcenter Enterprise and 
it’s mapping to the CATIA V5 product structure. Typical tasks discussed are CMI 

Preference conf iguration, loading models/ parts/ structures/ drawings stored in 
Teamcenter Enterprise into CATIA V5 and creating/ updating parts and drawings in 
Teamcenter Enterprise. One of  the main subsections deals with creating and saving 

CATIA V4 models. 

 

Predefined Object Structure 

The CATIA Teamcenter Interface contains the following predef ined object structure to 
support CATIA V5: 

Figure 66: CMI Structure for CATIA V5 

The relation ‘Is Described By’ exists between a part and a document. This relation can be 

created by dragging and dropping any document onto a part object. [Please refer to the 
Teamcenter Enterprise user documentation for managing relationships between 
Teamcenter Enterprise objects]. The document can contain at least one relation 

‘Attaches’ for CATIA V5 model elements. It is possible to attach more than one CATIA V5 
model to a single document, however, a particular model may only be attached once 
within a document. More than one document can be associated with each part.  

A structure is made of  one or more parts. Teamcenter Enterp rise knows two kinds of  Part 
objects: 

Assemblies

Components

 

Figure 67: Assembly and Component 

Is Described By Attaches

Assembly Document CATPart
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An assembly can contain other subparts (i.e. assemblies or components), whereas a 

component cannot contain other parts. 

 

Object Mapping  

Teamcenter Enterprise uses the product structure classes assembly and component, 
CATIA V5 uses CATProducts and CATParts. 

Both assemblies and components are mapped to CATProducts in CATIA V5.  
Models in Teamcenter Enterprise are represented by CATParts in CATIA V5. 

 

 

 

 

 

 

 

 

Figure 68: Assembly, Component, Model, CATProduct and CATPart 

The CATProduct and the CATPart are stored under dif ferent documents of  a part.  

 

CMI Preferences  

It is necessary to set the CMI preferences correctly in order to work with CATIA V5. The 

following actions open the CMI Preferences dialog window: 

Window-> CATIA-Workbench (the Workbench will then be open and active) 

Options-> Change Preferences-> CMI Preferences. 

The main preference settings for working with CATIA V5 are as follows: 

Work with CATIA Toggles modes between working with CATIA V4 or 

working with CATIA V5. 

Use CATIA V4 f iles Enables the loading of  CATIA V4 f iles to CATIA 

Use CATIA V5 CATPart f iles Enables the loading  of  CATParts 

Use CATIA V5 CATDrawing f iles Enables the loading  of  CATDrawings 

CATProduct Worklocation Storage location for saving CATProducts and other 

Catia V5 f iles 

Transfer CGR-f iles to Catia V5 Allows the user to send CGR f iles to CATIA V5 (see 

Working with CATIA V5 Released Cache) 

Transfer model-f iles to Catia V5 User can choose to not send model f iles to CATIA V5 
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Use CATIA V4 Files 

The Use CATIA V4 Files option is evaluated during 'Expand' and 'To Catia' in the 

Workbench and also during a Read command in CATIA. If  Use CATIA V4 Files = “False” 

then all V4 f iles are ignored by these functions.  

Use CATIA V5 CATPart files 

The Use CATIA V5 CATPart option is evaluated during 'Expand' and 'To Catia' in the 
Workbench and also during a Read command in CATIA. If  Use CATIA V5 CATPart Files = 

“False” then all CATPart f iles are ignored by these functions.  

Use CATIA V5 CATDrawing files 

Use CATIA V5 CATDrawing f iles = “True” loads all CATDrawings during “To Catia”.  

Transfer CGR files to Catia V5  

Transfer CGR files to Catia V5 is used in the context of  Catia V5. It means that CGR-f iles 

are transferred to the Catia V5 Release Cache instead of  CATParts / V4–models to the 

exchange-map. In standard CMI, this applies only for checked-in models.  

A prerequisite for this is that CGR f iles are provided by your PDM System. The CGR-f iles 

are expected in the same vault-location where the CatPart / V4-model are located, but you 
can also assign a specif ic CGR-location via the conf ig-variables CMI_CGR_HOST, 

CMI_CGR_VAULTLOC_PATH.  

There are three allowed values for “Transfer CGR f iles to Catia V5” 

No “No” suppresses transfer of  cgr-f iles 

Only CGR Only CGR” transfers the cgr-f iles instead of  CATParts / V4–models. 

CGR + geometry 
CGR + geometry” transfers the cgr-f iles to the “Release Cache” and 

the CatParts / V4–models to the exchange-map 

 

Product Structure CATIA V5 vs. Teamcenter Enterprise 

Product structures in Teamcenter Enterprise correspond well to product structures found 
in CATIA V5. The following graphic illustrates the core product structure in Teamcenter 

Enterprise. 
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Figure 69: Product Structure in Teamcenter 

Assembly CV5_CHAIR has subparts CV5_CHAIR_BACK and CV5_CHAIR_SEAT. Every 

subpart of  the top assembly has further subparts. For example CV5_CHAIR_SEAT has 

component CV5_CHAIR_LEG attached four times and a single ‘CV5_CHAIR_BOARD’.  

If  we expand the CV5_CHAIR_SEAT Component we f ind the part’s CATProduct and 

CATPart f iles attached to their respective document folders. The CATProducts are 
attached within Catia V5 Product Document folders and the CATParts are stored within 

the Design Document folder of  the Component. 
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Figure 70: Expanded Product Structure in Teamcenter 

This structure will be transferred via the CATIA Workbench to CATIA V5 and displayed in 

the Product Structure Navigator of  CATIA V5 as shown in the following f igure.  

 

Figure 71: Product Structure Navigator in CATIA V5 
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In the diagram above the ‘CV5_CHAIR_BACK’ Teamcenter Enterprise Parts of  object type 

“Component” are mapped to CATProducts within CATIA V5. 

The part ‘CV5_CHAIR_LEG’ demonstrates the deeper structure of  a part in CATIA V5. 
Immediately under the CATProduct ‘CV5_CHAIR_LEG’ you will f ind the icon for the same 

part ‘CV5_chair_leg.CATPart’. This node and all following levels picture the associated 

model of  the CV5_CHAIR_LEG and its characteristics. This is named the CATPart.  

 

 

You may also build completely new assemblies or extend current assemblies 

(including geometry) by creating your product structure in CATIA V5 and via the 
“Synchronization in Teamcenter” command which automatically creates the 

equivalent assembly in Teamcenter Enterprise 

 

 

By default, CMI uses a CATProduct with each Component, as shown above. It is 

also possible to have Components that only use a CATPart. See Use BOM  -- NO 

BOM geometries 

 

 

CMI Toolbar 

The following f igure shows the toolbars of  the CATIA V5 CMI module. Descriptions of  the 

toolbar and the command-icons follow the diagram. 

Read from Workbench

Create in Teamcenter

Update Teamcenter

SaveAs in Teamcenter

Update Teamcenter

AddTemp FromTeamcenter

Create V4 Model

Synchronize
Teamcenter

Create V4 Model

SaveAs V4 Model

Create/Attach Archive
CMI- In fo

Insert from Teamcenter

Highlight in Teamcenter

Build Visualization

Reconnect with Teamcenter

Modify non-Catia Archive Content

Save Local

Restore Local

 

Figure 72: CMI Toolbar in CATIA V5 

Using the CMI toolbar in the CATIA Product Structure Workbench it is possible to read 

f iles f rom the CATIA Workbench in Teamcenter Enterprise. You can then modify the 
geometry in your CATIA V5 session. The modif ications can be updated in Teamcenter 
Enterprise via the ‘Update Teamcenter or the ‘Synchronization in Teamcenter’ button in 

CATIA V5.  
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The icons ‘Create in Teamcenter’ and ‘SaveAs in Teamcenter’ are only active if  you are 

working with a CATPart in a CATPart-specif ic Workbench or with a CATDrawing in a 
CATDrawing-specif ic Workbench. The icon ‘Synchronization in Teamcenter’ is only active 

if  you are working in the Product Structure Navigator. 

CMI also supports storing CATParts as V4 Models. The icons ‘Create V4 Model’ and 
‘SaveAs V4 in Teamcenter’ are only active if  you are working in a CATPart-specif ic 
Workbench, but you can also create CATIA V4 model if  you’ve selected a CATPart in the 

Product. You can get the Teamcenter Information of  the CATParts, CATProducts, 
CATDrawings and CATIA V4 Models with the CMI Info Button if  you loaded the Product 

Structure with CMI to CATIA V5. 

The other commands will be described in more detail later in this chapter.  

 

 

An administrator can remove any CMI Command f rom the toolbars and menu, in 

order to keep the interface lean. Please see Customizing Manual for details. 

On UNIX the commands on subordinate toolbars are part of  the main toolbar. 

 

 

CMI Options 

The CMI options in CATIA can be found in the “Tools->Options” menu in the  

General->Compatibility section under the CMI tab. 

 

Figure 73: CMI Options dialog 
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Use one temporary product window for all CMI Workbench contents 

When this option is checked all top level Assemblies in the CMI Workbench are loaded 

under a temporary CATProduct in CATIA.  

 

Single Part Modus 

When this option is checked all CATParts of  a structure are loaded in separate windows 

during CMI Read. The rest of  the structure will not be loaded.  

 

Do not hide Products not from CMI Workbench 

When this option is checked CMI does not hide the any node in the Product structure 

during CMI Read. By default CMI hides all nodes in the CATIA tree not loaded by CMI. 

 

Deactivate geometry files not from CMI Workbench 

When this option is checked CMI deactivates all geometry nodes not loaded by CMI 

during the current CMI Read action in the Product structure.  

 

Use extra directory for non CATIA items in CMI-Archive 

Select an additional directory where non CATIA f iles (like jpeg, doc, …) are handled for 

CMI Archives. 

 

CATParts and CATDrawings in CATIA-Workbench in Teamcenter Enterprise 

CATIA V5 will read all expanded assemblies, single CATParts, CATDrawings or CATIA 

V4 models f rom the Teamcenter Enterprise CATIA Workbench. 

The following f igure shows a CATDrawing item and a CATPart item in the CATIA 

Workbench: 

 

 

Figure 74: CATIA Workbench with a CATDrawing item and a CATPart item 
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When you have transferred a CATPart f rom Teamcenter Enterprise to CATIA V5 via the 

CATIA Workbench, the part will be displayed in CATIA V5 in a new window.  

CMI for CATIA V5 also supports CATIA V4 models and CATIA V5 Drawing f iles 
(CATDrawings). CATDrawings may be included in assembly structures in Teamcenter 

Enterprise, however in CATIA V5 they will be displayed in separate windows as shown in 

the f igures below: 

All the normal CMI functions (Read, Update, Create and Save As) may be used with 

CATDrawings and CATParts within CATIA V5. 

 

Figure 75: Part Design Workbench for Read, Update,  

Create or SaveAs CATPart 
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Figure 76: Drawing Workbench for Read, Update,  

Create or Save As CATDrawing 

 

CMI toolbar: Read From Workbench 

With the ‘Read f rom Workbench’-button in the CMI Toolbar the contents of  the CATIA 

Workbench in Teamcenter Enterprise may be read into CATIA V5. The CATIA Workbench 
may contain CATParts, CATDrawings, CATIA documents, CATIA V4 models and 

assembly structures. 

If  you want to send one or more assemblies, CATParts or CATDrawings to CATIA follow 

these instructions:  

 

Drag and drop parts, drawings, models, assemblies or documents into the 

Workbench. 

Expand or Deexpand the assemblies in the Workbench. 
 

 Read Teamcenter CATIA items with ‘Read From Workbench’ icon . 

Every top-level item in the CATIA Workbench will be opened in a separate browser 

in CATIA V5. 

 

CMI toolbar: Update Teamcenter 

This command updates geometry and position information in Teamcenter Enterprise.  
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Modify the contents in CATIA. 

Write the modif ications back with ‘Update Teamcenter’ icon .  
 

 
Modif ied geometry, CATProducts and transformation matrices will be updated.  

 

 

Figure 77: Dialog Window for Update CATIA Models 

 

CMI toolbar: Synchronization in Teamcenter   

This command updates Teamcenter Enterprise with any changes made to your CATIA V5 

Product Structure.  The changes that will be ref lected in Teamcenter Enterprise include:  

• any geometry and position information changes 

• the creation of  any new CATParts/CGR and CATProducts that have been added 

to your Product Structure  

• the creation of  any new CATPart/CGR and CATProduct instances  

• the removal of  CATProducts f rom the Product Structure  

 

The list of  changes made to the Product Structure since the last 
Read/Update/Synchronize is presented in the form of  list of  operations to be performed in 

Teamcenter Enterprise. 

 

 

Modify your product structure in CATIA by adding a new CATPart/CGR, adding a new 

CATProduct, removing a product or by changing the geometry of  a CATPart. 

Write the modif ications back to Teamcenter Enterprise with the ‘Synchronization in 

Teamcenter’ icon .  
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The following dialog will appear, showing you which changes need to be written to 

Teamcenter Enterprise: 

 

Figure 78: The Synchronization in Teamcenter Dialog 

The dialog's Operation column shows which procedures need to be performed in 

Teamcenter Enterprise for each object and may be a combination of  the following:  

Update The f ile and positional changes of  any children will be updated in 

Teamcenter Enterprise. 

Create The object will be created in Teamcenter Enterprise. The object is 

completely new and not already in Teamcenter Enterprise. 

Link child At least one new parent-child relation will be created in Teamcenter 

Enterprise. This ref lects the addition of  a child - product in CATIA. 

Drop Child At least one parent-child relation will be deleted in Teamcenter 
Enterprise. This ref lects the deletion of  a child-product of  the object in 

CATIA. 

Prepare A CATPart has been brought into the product structure. It has been 
recognized as being f rom CMI/ Teamcenter Enterprise, but it requires 
preparation before being brought into the assembly in Teamcenter 

Enterprise.  Preparation could, for example, be the creation of  a 

General Document to attach the f ile to. 

 

The column Execute shows whether the operation will be executed or not. If  there is any 

reason why the operation cannot be executed, then the reasons will be shown in the 

Result column. 

 

 

If  the Process Next Operation button is pressed, the operation marked in the Next Op 

column by the > symbol is executed. 

If  the Process All button is Pressed, the list of  executable operations is worked through 

in the order shown on the screen. 

In both cases the results f rom Teamcenter Enterprise are shown in the Output Window 
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below the list.  

 

 
The update operation: 

For CATPart objects this means geometric information will be updated in Teamcenter 

Enterprise. If  the model in the assembly has been modif ied, a dialog window will 
appear in Teamcenter asking for conf irmation of  the model that needs to be updated in 
Teamcenter. (see f igure 76).  You may deselect the model if  you do not want the 

model to be updated. 

For CATProduct objects this means that the f ile will be updated in Teamcenter 

Enterprise. No user interaction is necessary. 

  

 
The create operation: 

For CATProduct objects, if  the nomenclature property f ield has been f illed in CATIA 

then no user interaction will be required and the following steps will be completed: 

- a Teamcenter Enterprise Part will be created 

- a document object will be created 

- the CATProduct f ile will be registered 

- the document will be attached to the Part and the CATProduct f ile to the 

document 

If  the nomenclature property f ield has not been f illed in CATIA, then the Create 
Assembly Teamcenter Enterprise dialog box will appear requesting the missing 
nomenclature attribute. When the nomenclature attribute has been f illed, the 

procedure completes as above. 

For CATPart/CGR objects a dialog window for creating a CATPart/CGR will appear - 

similar to ‘Action → Prepare’ in Teamcenter Enterprise. 
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Figure 79: Dialog Window to Create a new CATPart within the Product Structure in 

Teamcenter Enterprise 
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Figure 80: Dialog Window to Create a new CGR within the Product Structure in 

Teamcenter Enterprise 

 
Fill in the f ields and press ‘OK’ 

The CATPart/CGR will be created in Teamcenter Enterprise. Af ter your conf irmation 

a dialog window for creating a corresponding document will appear as follows.  
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Figure 81: Dialog Window to Prepare a Document in Teamcenter 

 

If  this document exists in Teamcenter Enterprise, the CATPart wil l be attached to 

this document, otherwise a new document will be created in Teamcenter Enterprise. 

  

 
The link child operation: 

This may only appear as an operation for CATProduct objects, as CATParts cannot 
contain sub-products. In Teamcenter Enterprise any new child CATProducts or 

CATParts will be attached to the Teamcenter Enterprise Part of  the parent object 

using the following methods: 

- if  the child is a CATPart, then the document attached to the child CATPart is 

attached to the parent Part object 

- if  the child is a CATProduct, then its Teamcenter Enterprise Part is attached 

to the parent Part to create the Part-Part relation. 

  

 
The drop child operation: 

This may only appear as an operation for CATProduct objects as CATParts cannot 

contain sub-products. Also, CATParts cannot be dropped in Teamcenter Enterprise 
(without customization). In Teamcenter Enterprise any child CATProducts deleted 
f rom the CATIA product structure will be detached f rom the Teamcenter Enterprise 

Part of  the parent object using the following method: 

- if  the child is a CATPart, then no drop will occur  

(see also Deleting NON-BOM Parts during Synchronize) 

- if  the child is a CATProduct, then its Teamcenter Enterprise Part is detached 

f rom the parent Part (the Part-Part relation is deleted) 

  

 

Af ter every operation the success or failure will be registered in the result column of  
the dialog. If  an operation fails the output window will provide you with the cause of  

the failure. 
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CMI Geometry  toolbar: Create in Teamcenter 

With this toolbar button a CATPart or CATDrawing f ile currently set active in CATIA V5 

can be created in Teamcenter Enterprise. A Teamcenter create dialog window appears to 

enable the user to set additional attributes. 

 

 

Design or load your local CATPart or CATDrawing. 

In CATIA V5 select the ‘Create in Teamcenter’ icon . 

 

 
A Teamcenter Enterprise dialog window appears. 

Fill in the f ields and press ‘OK’. 

A new CATPart or CATDrawing will be created in the Teamcenter Enterprise 

environment. 

 

 

Figure 82: Dialog Window for Create CATIA V5 Parts or CATIA V5 Drawings 

 

The Create in Teamcenter Enterprise command is available if  the CATPart or 
CATDrawing has been opened in a separate CATPart or CATDrawing Workbench 

window in CATIA V5. 

 

 

CMI Geometry toolbar: SaveAs in Teamcenter 

With this command a CATPart f ile or CATDrawing f ile currently set active in CATIA V5 can 

replace another in Teamcenter Enterprise. A CATPart or CATDrawing selected in 
Teamcenter Enterprise and then dropped into the Workbench will be overwritten by the 

contents of  the CATPart or CATDrawing in CATIA-memory.  
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Design or load your CATPart or CATDrawing in a separate window in CATIA. 

In CATIA V5 select the ’Save As in Teamcenter’ icon . 

 

 

Teamcenter Enterprise will request you to drag and drop an item into the CMI 

Workbench. 

In order to ‘Save As in Teamcenter’ with a CATPart, double click or drag the 
CATPart (or the document with an attached CATPart) to be overwritten into the 

CATIA Workbench in Teamcenter Enterprise. The CATPart active in CATIA V5 will 

then overwrite its contents.  The same process applies to CATDrawings.  

 

 

‘Save As in Teamcenter’ is only allowed if  the item (CATPart or CATDrawing) has 

been opened in a CATPart or CATDrawing Workbench window in CATIA V5.  

 

Please take care when you ‘Save As’ a CATPart which is used in a CATProduct -  a 

reference to the CATPart is stored within the parent CATProduct. 

 

CMI Geometry toolbar: Create V4 Model 

This command converts a CATPart to a CATIA V4 model and creates it in Teamcenter 

Enterprise. 

 

 

Design or load your local CATPart. 

In CATIA V5 select the ‘Create V4 Model’ icon  . 

 

 
A Teamcenter dialog window appears. 

Fill in the f ields and press ‘OK’ 

A new CATPart will be created in the Teamcenter Enterprise environment.  
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Figure 83: Dialog Window for Create CATIA Model in Teamcenter 

 

You may only create CATIA V4 Models f rom CATParts. These parts must be 

opened in a CATPart Workbench window or be selected in the Product Structure 

Navigator. 

 

 

CMI Geometry toolbar: SaveAs V4 Model in Teamcenter 

With this toolbar button a CATPart f ile currently set active in CATIA V5 may be created in 

Teamcenter Enterprise as a CATIA V4 model. A CATIA V4 model selected in Teamcenter 
Enterprise and dropped into the Workbench is overwritten by the contents of  the 

converted CATPart in CATIA-memory. 

 

Design or load your local CATPart. 

In CATIA V5 select the ‘Save As V4 in Teamcenter’ icon . 

 
Teamcenter Enterprise will request you to drag and drop an item in the Workbench.  

In order to ‘Save As V4 in Teamcenter’ with a CATPart, double click or drag a CATIA 

V4 model (or document with an attached CATIA V4 model) to be overwritten into the 
Workbench in Teamcenter Enterprise. Its contents will be overwritten by the 

CATPart active in CATIA V5 in CATIA V4 model format. 

 

 

The ‘Save As CATIA V4 Model’ toolbar button is only enabled if  the CATPart item is 

open in a separate Workbench window in CATIA V5. 

 

 

CMI toolbar: CMI Info  

This command displays the Information f rom Teamcenter Enterprise for CATParts, CGRs, 

CATProducts, CATDrawings and V4 Models.  

The “More …”-button displays attributes of  the correspondent Teamcenter-objects. The 

range of  attributes can be customized. 
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Figure 84: Information dialog window for CATProduct with “More Attributes” 

 

 

Select the CATPart, CATProduct, CATDrawing or V4 Model.  

In CATIA V5 select the “CMI-Info” icon . The appropriate dialog info 

window appears. 

 

 

 

You can also select multiple Catia items. Information will be displayed in a table. 
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Figure 85: CMI Information for multiple items 

 

CMI toolbar: Add Temp 

Allows the user to visualize a temporary structure together with the working one. 

For example, if  the user is making a design of  a car and wants to see if  the luggage boot 
is big enough, he can load a suitcase as a temporary structure by doing the following 

(supposing that the car structure is already loaded):  

 

 

Read an assembly (here the car assembly) into CATIA using the CMI toolbar Read 

command 

In CATIA V5 select the ‘Add Temp’ icon  

 

. 

 

Drop the assembly or model you want to add temporarily to CATIA (the suitcase) 
into the CATIA Workbench. Expand it as necessary. Click Action > To CATIA in the 

Workbench menu. Changes/expands you make to other assembly structures in the 

Workbench will not be sent to CATIA. 

Instead of  an Assembly, you can also drop a Saved Workbench Session 

 

 

CATIA comes to the foreground with both the original and temporarily added 
structures loaded in the same window - here the car and the suitcase structure. It will 

not be possible to make any changes to the temporarily added (suitcase) structure. 
The temporarily added part/structure is removed f rom the CATIA Workbench af ter 

you send it to CATIA. 
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All Partnumbers and Filenames in the temporarily added structure are pref ixed with 
“TMP#_”, where “#” is a counter in CATIA V5, beginning with 1. Every AddTemp will 

increase the counter. This pref ix is customisable by the customer. 

Limitations: 

• Product are not transferred to CATIA, the products will be represented by 

“CATIA Components”, only position information f rom Teamcenter is 

processed. 

• Standard Parts are not supported. 

 

Visualize multiple revisions of an Assembly using Add Temp 

Add Temp in Catia V5 can be used to load dif ferent versions (revisions) of  an Assembly 
or Model at the same time. In order to make this possible, the Part Numbers and File 

names of  the temporarily added assembly are pref ixed with “TMP#_”. 
 

 

In Catia V5, go to Tools->Options->Compatibility (Tab: “CMI”)and make sure that the 

option “Use one temporary product window…” is checked. 

 
Read revision B of  your assembly as described in CMI toolbar Read 

You will f ind that it is opened in Catia underneath a product tagged “CMI 

Workbench”  

 In CATIA V5 select the ‘Add Temp’ icon  . 

 
Find and expand Revision A of  your assembly. Send it “To Catia”.  

 

Revision A and B of  your assembly are opened in the same Window in Catia V5. 

You can overlay and position the assemblies relative to each other for comparison.  

 

CMI toolbar: Compare Version 

Similarly to Add Temp, Compare Version is used to load dif ferent versions of  the same 

assembly. However in this case, the version that is already open is read only and the 

version that is added can be modif ied. 

 

 

In Catia V5, go to Tools->Options->Compatibility (Tab: “CMI”)and make sure that the 

option “Use one temporary product window…” is checked. 

 
Read revision A of  your assembly as described in CMI toolbar Read 

You will f ind that it is opened in Catia underneath a product tagged “CMI 

Workbench”  

 In CATIA V5 select the ‘Compare Version’ icon  . 

 Notice that Revision A is renamed with the “TMP#_” pref ix. Revision A can no longer 

be modif ied and saved in Teamcenter. 

 
Find and expand Revision B of  your assembly. Send it “To Catia”.  

 

Revision A and B of  your assembly are opened in the same Window in Catia V5. 

You can overlay and position the assemblies relative to each other for comparison. 
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Use Synchronize Teamcenter to update Revision B of  the assembly. Notice that 

Revision A and all it referenced f iles are ignored and will not be modif ied in 

Teamcenter. 

 

 

 

 

CMI toolbar: Insert from Teamcenter 

Allows the user to load a CMI-structure under a selected product. 

 

 

Read an assembly into CATIA using the CMI toolbar Read command 

Select a product to be the root of  the inserted structure.  

In CATIA V5 select the ‘Insert from Teamcenter’ icon  . 
 

 

Drop the assembly-structure or a model you want to use in CATIA V5 into the CATIA 
Workbench. Expand it as necessary. Click Action > To CATIA in the Workbench 

menu. Changes/expands you make to other assembly structures in the Workbench 

will not be sent to CATIA. 

 

 

CATIA comes to the foreground with the selected product and the used structure.  
The dropped part/structure is removed f rom the CATIA Workbench af ter you send it 

to CATIA. 

Via Synchronize you can save the new Use-Relation in Teamcenter. 

 

CMI toolbar: Replace from Teamcenter 

Replace the selected product in CATIA by a dif ferent Part f rom Teamcenter.  

 

 

Read an assembly into CATIA using the CMI toolbar Read command 

Select a product to be replaced. 

In CATIA V5 select the ‘Insert from Teamcenter’ icon  . 
 

 

Drop the Part that you want to use in CATIA V5 into the CATIA Workbench. Expand 

it as necessary. Click Action > To CATIA in the Workbench menu. Changes/expands 

you make to other assembly structures in the Workbench will not be sent to CATIA. 

 

 

CATIA comes to the foreground, the selected product is replaced by the part or 
structure f rom Teamcenter. The instance name and positioning information is 
preserved. 

The dropped part/structure is removed f rom the CATIA Workbench af ter you send  it 

to CATIA. 

Via Synchronize you can save the new Use-Relation in Teamcenter. The previous 

relation is deleted. 
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Highlighting of CATParts, CATProducts and models in the CMI Workbench 

If  you want to highlight CATParts, CATProducts and models in the CMI workbench 

triggered by CATIA V5. 

 

 

In CATIA V5 select the CATIA models/parts you want to highlight in the CATIA 

workbench and choose the Highlight in Workbench command f rom the CATIA CMI 

toolbar. Now the models/parts are highlighted in the workbench as “Marked Item”. 

 

Highlight a part/model in the CATIA workbench. 

In CATIA V5 select the “Highlight in Workbench” icon . 

 

 

CMI Advanced Toolbar:  Local Save and Restore 

 Using Save Local the contents of  the Catia V5 session can be stored locally. 

This snapshot of  the session will persist even when Catia V5 is closed. 

 When the session is restored with Restore Local, you can continue your work 
as if  you had just used Read from Teamcenter, ie. you can perform Updates. 
The Restore Local command is only available when the Catia is empty – ie. no documents 
are open – to avoid conf licts. 

 

 

With Save / Restore Local you can avoid reading large assemblies f rom 
Teamcenter repeatedly. However, the status of  the data in Teamcenter may change 

if  you keep your local snapshot for a long time. It may get “stale”. 

 

The following restrictions apply: 

▪ Only one saved session is maintained at a time. 

▪ The session can only be saved when the data is up to date. Ie. there are no f iles 

in a modif ied state, and no new f iles.  

▪ The save/restore session does not restore f iles that were not loaded f rom the 

PDM system.  

 

CMI Advanced Toolbar:  Reconnect Teamcenter 

 

CMI recognizes f iles that have been loaded into Catia V5 through the Catia Workbench. 

Since it knows that they are f rom Teamcenter, it can update them there. 

Other f iles, that you load with eg. File→Open, it will not know. They will be regarded by 

Synchronize as new f iles, and it will create new Teamcenter objects for them.  
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If  you open a product structure f rom disk that contains f iles that are already in 

Teamcenter, you can use Reconnect Teamcenter to make CMI recognize these f iles. It 
will recognize Products if  the Partnumber is correct, and CATPart/model f iles based upon 
their f ilename. If  the CATPart is a BOM CATPart (Component) in Teamcenter, the 

Partnumber must also match. 

 

Figure 86: CMI Reconnect dialog 

There are three possible states: 

CMI-Unknown: CMI does not know this item at all. It would be created as a new Part in 

Teamcenter. 

Can be reused: CMI knows that this item is in Teamcenter. But it appears that in 

Teamcenter there is no instance known by the same instance name under the same 
parent item. Maybe it was deleted or is new. Synchronize would create a new instance of  

the existing Part in Teamcenter. 

Can be updated: CMI knows that the object as well as this instance is in Teamcenter. 

It can be updated in Teamcenter. 

Can not be updated:  CMI knows that the object as well as this instance is in 

Teamcenter, but it is not writeable and cannot be updated in Teamcenter. 

Archive content: The object is part of  a CMIArchive. 

Broken Link: A broken link cannot be reconnected. It will be ignored during 

synchronize. 

An asterisk (*) signif ies that the Reconnect Dialog recognized the item, but it is not yet 
reconnected. Items are actually reconnected when you close the dialog with [OK] . Click 

[Cancel] to keep them as unknown, e.g. if  you do want to save them as new Teamcenter 

objects. 

 

Reconnect does not create anything in Teamcenter or update any f iles. Use 

Synchronize to update data. 

 

 

Load a CATProduct into CATIA using File→Open 

In CATIA V5 select the Reconnect Teamcenter icon  . 

 

In the CMI Reconnect Dialog, click Select unknown. In this case, all lines will be 
selected. Click Reconnect selected. If  any items are recognized in Teamcenter, they 
will change their status. To reconnect these items, close the dialog with [OK]. Click 

[Cancel] to leave the dialog without reconnecting the items.  

 

Reconnected items that are writeable in Teamcenter will be in the “modif ied” state, 

to be able to update them in Teamcenter. 

Use Synchronize to create the unknown/new data and to update the reconnected 

f iles. 

 

If  you want to keep individual items as new, unselect them before you click 

Reconnect selected. 
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Use mapping file 

If  a mapping f ile was created when the product structure was f irst imported into 
Teamcenter, this f ile can be used to map the CATIA names to the names the products  
have in Teamcenter. Click Use mapping file to retrieve a mapping f ile that is attached to 

the top level Part f rom Teamcenter and map between external names and Teamcenter 
names. Import/Export using mapping f iles needs to be enabled by your CMI administrator. 

See Optional CMI Functionality. 

 

Synchronize Configuration 

Here you can control for individual f iles how they should be treated during Synchronize, as 

well as how they are going to be reconnected. 

Update/New radio buttons 

In order to be updateable, a f ile has to be connected with Teamcenter. If  the f ile is 

connected, but you rather want to store it as a new f ile, c lick New to disconnect the f ile, so 
that it will be created as a new object in Teamcenter during Synchronize.  The same allows 

to copy a part or data item that you have originally opened f rom Teamcenter. 

Ignore checkbox 

Ignore this Item in Synchronize (neither create a new item nor update) 

Part number, Instance name, File name 

If  the f ile is archived in Teamcenter under a dif ferent name than it has in CATIA, you can 
suggest the name here. It will take the place of  the name in CATIA when Teamcenter is 

searched for the item. 

Reconnect CMIArchives checkbox 

By default, Reconnect does not search Teamcenter for CMIArchives to reconnect a 
CATProduct. Check Reconnect CMIArchives to also search for CMIArchives.  Keep in 

mind, however, that several dif ferent Archives can contain a root product with the same 

part number or f ile name. If  this is the case, you will be asked to select one of  these.  

 

Handling of CATDrawings 

CATDrawings can be included in your assembly structures in Teamcenter Enterprise. All 
the usual functions (Read, Update, Create and Save As) are supported  for CATDrawings 

in CATIA V5 via the CMI Toolbar.  

CATDrawings may be created for single models or for assemblies. There are however 
several caveats when working with CATDrawings and CMI, dependant on the context of  

the CATDrawing. 

Creating a CATDrawing From a Single Model 

When creating a CATDrawing for a CATPart, always send the CATPart singly (without its 
assembly) f rom Teamcenter Enterprise to CATIA V5, and then create the CATDrawing.  
This method will preserve the context of  the CATDrawing - irrespective of  whether the 

CATPart is later loaded into CATIA singly or as part of  an assembly. If  you later make 
changes to the CATPart, and you wish the CATDrawing to update and ref lect the 
changes, you must load both the CATPart and the CATDrawing in CATIA V5 using CMI 

before you update the CATDrawing.  

 

 
Drag and drop the CATPart into the CMI Workbench. 

Select:  Action > ToCatia 
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Create the CATDrawing with the usual CATIA V5 functions. 

Select the ‘Create in Teamcenter’ icon  

 

Creating a CATDrawing From a Product Structure 

 

 
Drag and drop the assembly into the CMI Workbench. 

Select:  Action > ToCatia 

 

 

Create the CATDrawing with the usual CATIA V5 functions. 

Select the ‘Create in Teamcenter’ icon  

 

 

CMI can f ill in Drawing title blocks with attributes f rom Teamcenter. This requires 

customization. See Customizing Guide. 

 

 

Handling of cgr and model files 

In CATIA V5 cgr and model f iles are managed as representation of  an embedded 
component in the product structure. It is not possible to modify such a representatio n 

directly. It is only possible to use the Save As function of  CATIA V5 to create a new cgr or 
model f ile of  a loaded CATPart or CATProduct. To update the representation you have to 
replace the original representation by the new representation.  

 
Load an assembly which uses a cgr or model in the product structure.  
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Figure 87: Manage representations dialog 

Use the “Replace” function to use the cgr or model f ile with a new representation.  
 

 

Figure 88: Manage representations dialog - Replace 

Use CMI Update or Synchronize functionality to update the new cgr or model f ile in 

Teamcenter. 
 
During the CMI Update / Synchronize process CMI replaces the original representation 

f ile in the exchange directory by the new representation f ile and changes the “Source” 
path of  the representation back to its original value. Then the new representation f ile 
(which has the name of  the old f ile) is updated in Teamcenter.  

 
To use this function you need write access to the cgr or model data item in Teamcenter. 
Although the cgr or model is represented in an embedded component of  a higher 

CATProduct you need no write access to the CATProduct.  
 
Restrictions: 

- There must be only one representation in one component.   
- The “Name” of  the representation must not change. 
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Handling of CATProcess 

 

CATProcess is a CATIA V5 f ile type. In Teamcenter Enterprise the CATProcess f ile 

can be registered with the standard Teamcenter function register (Figure 89). 

 

 

Figure 89: Teamcenter Register File dialog 

 

Af ter registering the CATProcess f ile the CATProcess data item can be attached to 
an Assembly. Figure 90 shows an example for a process element with an attached 

CATProcess data item. 

 

.  

Figure 90: Part with attached CATProcess data item 

 

Af ter dropping the Process Element in the CATIA Workbench CMI will detect the 
attached CATProcess and changes the icon of  the dropped Process Element. Figure 

91 shows an example for a dropped Process Element. 
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Figure 91: CATIA Workbench with dropped Process Element 

 

Af ter an expand of  the Process Element in the CATIA Workbench the expanded 
Parts are by default marked as Product view elements. Figure 92 shows an 

expanded structure. By default all child items of  the Process Element are classif ied 
as Product View. By customization this can be enhanced to Product View and 
Resource View. The views are later used in the CATIA V5 module to def ine the View 

where the Assembly should build in. 

 

 

Figure 92: Expanded Process Element 

 

Af ter sending (Action->To CATIA or The Read Command in CATIA V5) the CMI 
Workbench content to CATIA V5 the CATProcess document is loaded in the 

CATProcess Workshop of  the CATIA V5 application.  

 

 

The ProductView Assembly is built into the Product List. As described above, the 
adding of  Assemblies to the Resource list can be customized in Teamcenter. Figure 

93 shows the opened CATProcess in CATIA V5. 
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Figure 93: Loaded CATProcess in CATIA V5 

 

Changes in the CATProcess document in CATIA can be updated with the Update 
Command of  CMI in CATIA V5 (see CMI toolbar: Update Teamcenter). All 

Documents in the ProductList and ResourcesList, which are loaded f rom CMI will 

also be updated. 

 

 

You can also Save a CATProcess that you have created in CATIA using 
Synchronize Teamcenter. CMI will create a new Assembly item for the Process, that 
references the products and resources. The CATProcess is handled much like a 

CATProduct. 
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Handling of CMIArchives 

CMI supports the use of  CMIArchives. A CMIArchive is a data item in TeamCenter which 

contains a CATIA V5 structure. The Structure has one root item which can be a 
CATProduct or a CATPart. If  the root item is a CATProduct, it can contain more items of  

type CATIA V5 Component, CATIA V5 CATProduct or CATIA V5 CATPart. 

In the following sections the handling of  CMIArchives is described in detail.  

 

First open the CMI Workbench in Teamcenter and drop an Assembly into the CMI 
Workbench (see Figure 94). Af ter sending (Action->To CATIA or The Read 

Command in CATIA V5) the CMI Workbench content to CATIA V5 the product 

structure is loaded in the CATIA V5 application. 

 

 

Figure 94: Assembly dropped in the CMI Workbench 

 

Figure 95: Loaded Assembly in the CATIA V5 
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Figure 95 shows the loaded Assembly Product in the CATIA V5. Now we add the 

Structure which should be attached as CMIArchive as child items to the Assembly1. In our 

example the three possible types are added under the Root item (Figure 96). 

 

Figure 96: CMIArchive Root item with three children 

 

Select the root Item of  the Product which should be attached as CMI Archive (see 
“RootItem (RootItem.1)” in Figure 96). The parent object of  the selected must be 
loaded f rom CMI. The CMIArchive will be attached to an existing CMI structure by 

using the” Attach Archive” Toolbar button. 

In CATIA V5 select the “Attach Archive” icon.  

 

 
In the TeamCenter client the Dialog shown in Figure 97 will appear. 

 

 

Figure 97: Create Archive Dialog in TeamCenter 

 

Af ter pressing the OK Button the Prepare dialog for the Teamcenter Document is 
presented to select an existing or to create a new Document for the Archive. In the 



 

116  CMI User Manual 

example (Figure 98) we create a new document in TeamCenter. 

 

 

Figure 98: Document create dialogs in TeamCenter 

 

Af ter creating all Objects and relations in TeamCenter the User gets the Information 

f rom TeamCenter in a Message Window within CATIA V5 (see Figure 99). 

 

 

Figure 99: CMI Message Window 
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CMI has created a new CMIArchive data item and a document in TeamCenter. The 

Document is linked with the Assembly. Figure 100 shows the expanded CMIArchive 

af ter the “Expand Models” Option was used in the CMI Workbench.  

 

 

Figure 100: Expanded Archive Item in the Workbench 

 

In CATIA V5 the TeamCenter information is attached for the CMIArchive. The CMI 

info dialog shows the Information for the CMIArchive object in CATIA V5.  

 

 

Figure 101: CMI Archive Info 

 

The CMIArchive can be modif ied or extended, e.g. by adding new CATParts. The 
changed CMIArchive can be updated in TeamCenter with the Standard CMI Update 

Commands. 

Use BOM Parts in CMI Archives 

 

It is possible to use BOM Parts f rom Teamcenter within an Archive. To enable this 
functionality, the administrator should set the following variable in the CATIA V5 
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environment: 

CMI_ARCHIVE_BOM_CHILDREN = ON 

 
 

BOM Parts can only be inserted into already existing Archives. 
 

 

Load an existing Assembly f rom Teamcenter. 

Insert the Root product of  the product structure you want to become a CMI Archive.  

Use Create/Attach Archive to create the CMIArchive. 

Load a Part or Assembly f rom Teamcenter and insert it into a product that is part of  

the CMI Archive; or use the Insert from Teamcenter command. 

 

 

Figure 102: CMIArchive in BOM Assembly 

An Archive with BOM Parts can only be updated with Synchronize Teamcenter. CMI 
will create an Assembly Structure relation between the BOM Part and the Assembly 

that attaches the Archive. 
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Figure 103: Synchronize dialog with BOM CMIArchive 

For that reason you can only attach BOM Parts if  the Archive was loaded together 

with its Teamcenter Assembly. 

 

 

Figure 104: BOM Assembly with CMIArchive 

The transformation (positioning information) stored in Teamcenter for this part  instance is 
a summary of  the transformations that are hidden in the CMIArchive; so the positioning 
eg. in a DMU is correct relative to the Assembly. 

 
 

 

Since in CATIA it may not be obvious which parts of  the product structure are stored 

in the CMIArchive and which are individual parts in Teamcenter, the  ability to use a 
BOM Part under a CMIArchive should only be used for specif ic use cases, where 

this is implicitly clear to the user. 

One use, for instance, is to build supplier Parts into an OEM structure, where 

dif ferenciation may be possible by the dif ferent naming conventions. 

 



 

120  CMI User Manual 

 

Handling of CATAnalysis 

Store a CATAnalysis file 

CATAnalysis f iles can be stored in Teamcenter as a DataItem The Analysis is attached to 
the Teamcenter Part of  the product or CATPart that it is referencing. It is handled in a 
similar way as a CATDrawing – normally the Analysis f iles are not loaded; it is loaded if  it 

is explicitly expanded in the Workbench. 

Unlike with a CATDrawing, the assemblies referenced by the Analysis are updated if  you 

use the Synchronize Teamcenter function in the Analysis Workshop. 

  

 

To manage CATAnalysis as a native f ile, your administrator should add the following 

setting to the CATIA environment: 

CMI_STORE_ANALYSIS = ON 

 

 
Load an Assembly or Part f rom Teamcenter. 

 

 

 

In CATIA, generate the Analysis. 

Use Synchronize Teamcenter to store the CATAnalysis f ile in Teamcenter. 

 

 

Figure 105: CATAnalysis 

Synchronize will also update the Assembly the Analysis is referencing.  
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In Teamcenter, the Data Item for the Analysis will be created and attached to the 

Document of  the Part or Assembly for which the Analysis was generated.  

 

 

 

  

 

 

 

 

 

 

 

 

 

Figure 106: Analysis 

 

 

To read the Analysis, Drop the Part into the CMI Workbench and expand the 

Analysis with Expand V5 Analysis. 

 

 

Figure 107: Expand V5 Analysis 

You can also drop the Analysis f ile into the Workbench, but in order to update the 

Analysis results you should load and expand the Assembly along with its Analy sis.  

Analysis using a CMIArchive file 

The CATIA V5 data type CATAnalysis can also be stored in a CMIArchive along with a 

snapshot of  the product structure (see also Handling of  CMIArchives). 

 

Read an existing product structure document to CATIA V5 (Figure 108). 

 



 

122  CMI User Manual 

 

Figure 108: Existing product structure element loaded by CMI 

 

Attach an existing CATAnalysis f ile with the CATIA V5 functionality add existing 

component (Figure 109). 
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Figure 109: CMI Product with existing CATAnalysis. 

 

Select the Analysis in the Product structure and use the Attach Archive Function 

(see Handling of  CMIArchives). 

 

The result is an new CMIArchive with the CATAnalysis f ile, CATProducts, CATParts, 

and the optional CATAnalysisResults f ile, which is attached to the existing 
PartNumber. Figure 110 shows the PartNumber with the new CMIArchive. attached 

to it. 

 

 

Figure 110: CATIA Workbench after Expand model on PartNumber 

 

The newly created Archive can be dropped into the CATIA Workbench and loaded to 

CATIA with the Read command. 
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Figure 111: Existing CMIArchive with CATAnalysis loaded by CMI 

 

The result is the CATAnalysis document in CATIA V5. 

Changes made by the user can be updated with the standard CMI-Update 

commands. 

 

 

If  you only have the V5 GPS product but no t a GAS license, you can still store a 

CATAnalysis in a CMIArchive. 

Your administrator should add the following settings to the CATIA environment:  

CMI_ENABLE_CRE_ANALYSIS_ARCHIVE=ON 

CMI_ANALYSIS_ARCHIVE_OWN_WINDOW=ON 

With these settings, you can create a CMIArchive out of  the “Analysis Manager”. The 
second setting ensures that CATAnalysis opens in a separate window, even if  the 

CMIArchive is attached to an Assembly. 
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Working with CATIA V5 Released Cache 

CMI supports the use of  CGR-f iles in the release cache of  CATIA V5. For this purpose the 

Teamcenter customization has to store the CGR-f iles of  Catia-models in a specif ic CGR-
Vault. During To Catia these CGR-f iles are copied to the Released Cache instead of  the 
Catia-models to the exchange-map. In CATIA V5 the CGR-f iles are loaded in visualization 

mode.  

 
CATIA-Workbench: Options -> Change Preferences -> CMI Preference. 

Set “Transfer CGR-File to CATIA V5” to “Only CGR”/ “CGR + geometry” 

 

 

TOOLS>OPTIONS: Set “Work with the Cache System” to “On” and set the path to 

the released cache. 

“Check timestamps” must be “On”. 

 

 

 
Figure 112: CATIA Options - Cache Management 

For further information on the preconditions for the CGR-f ile-handling and for 

customization hints refer to the same chapter in the customization manual. 
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Support of external references 

With the commands Update/Create/Save As/Synchronize CMI reads out the external 

references f rom CATParts and CATDrawings to other CATIA documents.  
In TC Enterprise a customizing point is available to handle the CATIA V5 link information 
provided via CMI. 

 
In TC Enterprise links between CATParts (CCP) can be managed. Each link of  a CATPart 
to another CATPart is represented by a “depends on” relation.  

 
In CATIA V5 the functionality “Get referenced documents” automatically loads the 
referenced documents f rom TC Enterprise into the current CATIA V5 session.  

 
If you want to leverage this functionality, please contact us at cmi_support@t -
systems.com 

 

 

Viewer integration for JT (PLMXML) and CGR (3DXML) 

With the “To viewer” command the content of  the CMI Workbench can be sent to a 
specif ic viewer to obtain a quick preview out of  TC  Enterprise. This functionality is also 

available without a CATIA V5 installation! This functionality works OOTB with two f ile 

formats and protocols: 

▪ JT format – based on the PLMXML protocol the UGS JT viewers (JT2GO 

http://www.jt2go.com; TC Visualization) are supported. 

▪ CGR format – based on the 3DXML protocol the Dassault Systèmes viewer 

(http://www.3ds.com/products-solutions/3d-for-all/3d-xml) is supported. 

   

Figure 113: Integrated viewers 

Prerequisites 

CGR or JT f iles respectively must be provided by your Teamcenter PDM implementation. 
CMI may have to be customized to use them. 

The viewer executable must be conf igured by the administrator.  
See CMI 8.8 Customization Manual for the necessary steps. 

http://www.jt2go.com/
http://www.3ds.com/products-solutions/3d-for-all/3d-xml
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Usage 

Expand a product structure in CATIA Workbench. Action-> To Viewer will send the 

actual Workbench content to the Viewer. 

Action-> Marked Items->Marked To Viewer will send the marked Items to the 

Viewer. 
 

 

Figure 114: To Viewer action 

In order to exclude the CGR that are provided exclusively for viewing, the Model Filter 

preference in the CATIA Workbench is extended by a Viewing model type (CATIA V5 

Viewing) which will only be sent to CATIA if  Use model filter is set. 
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Figure 115: Model Filter Preferences dialog 

Configuration 

Directory and format (3dxml, pdmxml, etc.) are conf igurable in preferences.  

New Viewer Conf iguration in options-> Change Preferences Menu option. 

 

Figure 116: Change Viewer Preferences 

The Viewer Map directory def ines the local Directory which is used for the storage of  the 
viewer f ile and the related viewing f iles. 
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Figure 117: Viewer Preferences dialog 

 

Interoperation with VisMockup 

An assembly that was opened into VisMockup f rom the CMI Workbench with the “To 

Viewer” functionality can be imported back into CATIA V4/V5 based on conf igurations or 

selections made in VisMockup. 

 

In order to send the conf igured product structure f rom VisMockup to CATIA (V5 or V4), 

you need to export it f rom VisMockup as plmxml. You can keep the f ile name. 

 

  

Figure 118: Export from VisMockup 

In the Workbench click File->Viewer File To Catia to have CMI mark-up the product 

structure and automatically send it to Catia via the Marked Items To Catia functionality.  

  

Figure 119: Select Viewer File Name dialog 
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Only those geometries that were selected as visible in VisMockup will be opened in 

CATIA. 

  

Figure 120: Opened in CATIA 

 

Expand for Visualization 

The context menu of  the Catia Item representations in the CATIA Workbench contains a 

new option “Expand for Visualisation. 

The option expands the selected Branch over multiple levels with models displayed. If  a 
part with an attached Visualization-model is found the expand is stopped at this node and 

only the Visualization-model is expanded. 

 

Figure 121: Result of an “Expand Multiple Levels” 
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Figure 122: Result of an “Expand for Visualization” 

Figure 121 shows a normal expand multiple level with all structures and models. Figure 
122 shows that the second part contains a Visualisation f ile which represents the whole 

part with models and substructures.  

In CATIA V5 a new menu item Build Visualization is available that builds up or updates a 
visualization f ile f rom a selected product and stores the visualization under the selected 

item. These cgr can then be created/updated with the CMI Synchronize command. 

 

You can also use CATParts as a visualization f ile by setting the CATIA Model Type 
Attribute to CATIA V5 Visualization. CMI does not control the content or topicality of  the 

visualization f ile. 

 

Catalog Management 

CMI can also manage CATCatalog f iles in Teamcenter. PLM compatible Catalogs 
reference f iles and Parts that are actually stored in the PDM system. If  the user opens or 

inserts a f ile f rom the Catalog, CMI retrieves the corresponding data f rom Teamcenter. 

By default CMI retrieves the exact revision of  a Part that was inserted in the Catalog, but a 
mode where the Part Master is referenced in the catalog is also supported. In o rder to 

create Master-based catalogs, set 

CMI_DYNAMIC_CATALOG=ON 

in your CATIA environment. 

Manage Catalogs 

 
The administrator needs to set CMI_ENABLE_CMICATALOGCMD=ON in the Catia 

Environment, to enable the Manage Catalogs function. 

The Manage Catalogs button is enabled when you have a CATProduct active. It allows to 

retrieve CATCatalogs f rom Teamcenter for browsing. 
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Figure 123: Select Catalog for Browsing dialog 

Pick f rom the list of  catalogs available in Teamcenter.  

The catalog will be opened in the Catalog Browser. 

 

Figure 124: Catalog Browser 

Double click an end chapter to open the f ile or Part f rom the PDM system. You cannot use 

Open Document or Open As New Document in this context.  
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Read Catalog 

 
The administrator needs to set CMI_ENABLE_CMICATALOGREADCMD=ON in the Catia 

environment in order to enable the Read Catalog function.  
Read Catalog allows to retrieve CATCatalogs f rom Teamcenter for editing.  

 

 

Figure 125: Select Catalog for Editing 

Pick f rom the list of  catalogs available in Teamcenter. 

The catalog will be opened in the Catalog Editor. 
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Figure 126: Select Document in Session 

Use Select document in session to build the catalog f rom Parts or f iles that were opened 

f rom Teamcenter via CMI. 

Update or Create Catalog 

 
 

The administrator needs to set CMI_ENABLE_CMICATALOGUPDCRECMD=ON in the Catia 

environment in order to enable the Update and Create function for CATCatalogs.  
 
Update or Create Catalog allows to save new or updated CATCatalogs in Teamcenter. It 

will manage the necessary keyword attributes so that the Parts contained in the catalog 
can be retrieved f rom the Teamcenter database instead of  the local f ile system. 
 

Af ter starting the Update or Create Catalog command the catalog document is analyzed 
and the following dialog is shown: 
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Figure 127: Catalog synchronize dialog 

For new catalogs that were not already opened f rom Teamcenter, the user can change 
the f ile name which should be used in Teamcenter. 
 

The Type can be „Open“, „Open as copy“, and „Instantiate“. These types describe the 
way in which the parts will be handled when the catalog is used  

• Open: Open the referenced object in CATIA so that the existing Teamcenter part 

is used (e.g. standard part). 

• Open as copy: Open the referenced object in CATIA so that it will be recognized 
as a new Part in Teamcenter (e.g. templates). 

• Instantiate: Instantiate is used for Features and Power copies which will be 
instantiated. 

The Status Field can be “Updated”, “Loaded”, “Not known”, and “Created by CMI” 

• Loaded by CMI: The part is f rom PDM and already was in the Catalog at load 

time. 

• Updated by CMI: The Part is f rom PDM but the Type was changed. 

• Not Known by CMI: The Part is not f rom PDM 

• Created by CMI: The referenced File was opened f rom PDM and is new in the 
Catalog. 

 
Af ter Pressing the Synchronize button CMI will check all entries and if  there are unknown 

entries, the user must conf irm, that he will continue:  
 

 

Figure 128: Confirm to continue Sync operation 
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This indicates that there is a Part that is not managed by PDM. 
 
Next the Catalog is registered or updated in Teamcenter: 

 

Figure 129: Successfully finished Synchronize Catalog 

Using Macros / CATScripts in Catalogs 

 
 

Set CMI_ENABLE_CMICATALOGINSERTSCRIPTCMD=ON to enable the Insert CATScript 

from Teamcenter command. This allows to reference CATScripts that are held in 
Teamcenter in existing or new catalogs. 
To use a CATScript in a Teamcenter managed catalog the CATScript must already be 
registered in Teamcenter, as a CATIA Script class object. Copy your CATScripts to your 

Worklocation and register them in Teamcenter. 
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Figure 130: Register CATIA Script dialog 

To insert CATScript macros into a Catalog, open the Catalog for editing. To open a 
Catalog that is already managed in Teamcenter for editing, use the Read Catalog 

command. 
Select an end chapter. Click the Insert CATScript from Teamcenter command. A 
Teamcenter query for CATIA Scripts will appear.  

 

 

Figure 131: Query CATIA Script dialog 
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Pick a CATScript f rom the list. The CATScript will be inserted under the selected end 
chapter in CATIA. The keyword attributes for Teamcenter will be f illed in automatically. 

 

Figure 132: Select CATScript 

 

 

Figure 133: Inserted CATScript 

If  the catalog already references a CATScript and you want to connect it with 

Teamcenter, Select the existing CATScript reference instead of  the end chapter. 
 
Finally, to store the modif ied catalog in Teamcenter, use the Update or Create Catalog 

command. 
 

 

Figure 134: Synchronize Catalog dialog 

Now you can use the catalog to execute the CATScript that is stored in Teamcenter, with 

Manage Catalogs. 
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Optional CMI CATIA V5 functionalities 

There are numerous CMI features that are not enabled in OOTB CMI. Of ten these 

support specif ic methodologies used by individual CMI customers. These features are 
usually enabled by an administrator, by setting environment variables.   

Automatic CATDUA 

 To clean CATIA f iles that are stored in Teamcenter with the f ile based CATDUA 
utility you can use the Read with CATDUA command. 
In order to enable this command the following setting must be present in the CATIA 
environment: 
CMI_ENABLE_CMICATDUAREAD=ON 

 
The CMI CATDUAV5 integration needs a template conf iguration f ile to run CATDUAV5. 
The conf iguration f ile can be generated like described in the CATIA documentation: 

“Using CATDUA V5 outside an interactive Session” 
Use the procedure described in “Method 2: Accessing the Batch Interface from the 
CATUTIL / CATDUA V5 Batch Tool” to def ine the batch parameters. Make sure the 

“Document Selection” is empty. Save the conf iguration f ile to CMI_CATDUAV5.xml: 
 
 

The conf iguration f ile CMI_CATDUAV5.xml must be available on every client.  
The following variable must be set to point to the CATDUAV5 conf iguration f ile:  
CMI_CATDUAV5_CONFIG=<path>\CMI_CATDUAV5.xml 

Figure 135: CATDUAV5 dialog 
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Use  f rom the CMI toolbar to read the data that you want to clean. 
Select the cleaning method you want to use: 

Figure 136: CMI CATDUAV5 Integration dialog 

“Clean Geometry Files” uses CATDUAV5 for all CATParts and CATDrawings to be 
loaded f rom the CMI Workbench. 
“Clean Structure” uses CATDUAV5 for all CATProducts to be loaded f rom the CMI 

Workbench. 
 
“OK” starts the “Read f rom Workbench” and launches the CATDUAV5 utility before 

loading the f iles.  
“Cancel” aborts the Command. 
Af ter cleaning the f iles the result is shown in the web browser, it can be found in 

%CMIXMAP%\CMI_CATDUA_Result_<YYYY><MM><dd><hh><mm><ss>.htm 

Figure 137: CATDUAV5 Global Results 

After inspection, you can update the cleaned f iles in Teamcenter. If  you do not update, 
the changes made by CATDUAV5 are not stored. 
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Note: 

Cleaning f iles may take a long time. 
 
Attention: 

For f iles that are already open, CMI cannot load the version that was cleaned by 
CATDUA. Make sure that you close the f iles that you want to clean. 

   

Verification of CATIA Release 

CMI can check the CATIA version of  f iles against the current CATIA session during Read. 

This can be used to avoid loading a document f rom a newer CATIA release to an older 

CATIA version. 

The CATIA Release/SP/HF that was used to save a f ile is stored in Teamcenter.  

To enable the check, set the following in the Teamcenter Conf iguration:  
 
set CMI_VALIDATE_CATIA_VERSION “ON”; 

 

Figure 138: CATIA version verification 

Representation Formats in CATIA V5 

The CATIA V5 module can be conf igured to support CATIA V5 shape representation f iles 

in a generic way. CATIA V5 Representation f iles can be used in a product structure and 

are handled in a similar fashion to V4 Models. 

To enable support for specif ic Shape Representations, an administrator can set the 

following variable in the Catia V5 environment: 

CMI_REP_FORMATS={3dmap}{CATShape} 

In this example the 3dmap and CATShape Representation formats will be handled by the 

CMI Catia Module. (Figure 139 and Figure 140) 

Other Formats that may be relevant are stl and jt.  
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Figure 139: Representation formats in CATIA V5 (CATIA Workbench) 

 

Figure 140: Representation formats in CATIA V5 (CATIA V5) 

Use BOM  -- NO BOM geometries 

The CATIA V5 module can handle two dif ferent types of  CATParts.  

• BOM relevant and 

• NON BOM relevant. 

NON BOM Relevant CATParts 

NON BOM relevant CATParts are CATIA V5 geometry f iles which are stored as a model 
under a Part in Teamcenter. In CATIA V5 the Part and model is build up as CATProduct 

and CatPart (see Figure ). 

 

Figure 141: Mapping for NON BOM parts in Teamcenter and CATIA V5 

Teamcenter 

 
CATIA V5 
 
 

 

CATIA Workbench 
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BOM Relevant CATParts 

BOM relevant CATParts are CATIA V5 geometry f iles which are stored as the only model 
under a Part in Teamcenter. In CATIA V5 the Teamcenter Part is represented by a 

CATPart (see Figure ). 

 

Figure 142: Mapping for BOM parts in Teamcenter and CATIA V5 

The option to use the BOM and NON BOM parts must be conf igured by the Administrator. 

 

The user is able to decide which type of  geometry mapping should be used in Syncronize 

command, Create command and SaveAs command.  

To conf igure this behaviour, an administrator can set the following variable in the Catia V5 

environment: 

CMI_ENABLE_ASK_FOR_BOM_PART=ON 

The default can be set with 

CMI_BOM_PART_DEFAULT_FOR_SYNC= one of  {BOM | NOT_SET | NOBOM}  

NOT_SET: forces the user to make a choice 

BOM: by default, creates a BOM CATPart 

NOBOM or not def ined: Creates NO BOM CATParts (CMI OOTB behaviour) 

Synchronize  command 

The Synchronize command has a new function button Edit PDM-Part category in the 

Synchronize dialog. 

 

Figure 143: Synchronize dialog with enabled Edit PDM-Part category button 

(1) 

(2) 

Teamcenter 
 

 
 

CATIA V5 CATIA Workbench 
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This button is enabled when a line with a CATPart, model or CGR is to be created. Then 

the user can select the BOM or No BOM type in the Edit new PDM-Part category (see 

Figure ) 

For the BOM type Teamcenter will create a new Part, document and data item. 

For the No BOM type only the data item will be created.  

If  NOT_SET is selected, the Synchronize command will not start. 

 

Figure 144: Edit new PDM-Part category 

Create command 

After starting the Create command the user is asked for the type of  the part which should 

be created in Teamcenter. Figure  shows the part type ask dialog and the user has the 

possibility to choose a BOM type, a No BOM type or to cancel the command. 

 

Figure 145: Part type ask dialog with Create command 

For the BOM type Teamcenter will create a new Part, document and data item.  

For the No BOM type only the data item will be created. 

SaveAs command 

After starting the SaveAs command the user is asked for the type of  the part which should 
be used in Teamcenter. Figure  shows the part type ask dialog and the user has the 

possibility to choose a BOM type, a No BOM type or to cancel the command. 

 

Figure 146: Part type ask dialog for SaveAs command 

For the BOM type Teamcenter will create a new Part, document and data item.  

For the No BOM type only the data item will be created.  
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Design Tables 

  

CATIA V5 Design Tables can be stored in Teamcenter. Both CSV and Excel f iles are 

supported. A Catia V5 specif ic Dependency relation is created between the CATPart and 

its Design Table. Design tables referenced by CATParts and CATProducts are supported. 

This functionality needs to be enabled in the Teamcenter conf iguration:  

set CMI_DESIGN_TABLES “ON”; 

To use Design Tables for CATProducts also, CMI_USE_DTFORPRODUCT = ON needs 

to be set in the Catia V5 conf iguration.   

 

 

Figure 147: Synchronize with Design Table 

Design tables are not stored by default because of  performance considerations; also, you 

need a sound methodology if  you allow the use of  design tables in your methodology, 

since design tables have the power to change your product structures. 

Update Position 

To enable this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_CMIUPDATEPOSITIONCMD=ON  

This function updates only the transformation matrices in Teamcenter. The CATProducts 

and CATParts are not updated.  

Update Parts 

To get this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_CMIUPDATEPARTCMD=ON 

This function updates all modif ied CATParts in Teamcenter. Transformatio ns and 

CATProducts are not updated.  

Restore Positions  

To enable this function the administrator has to set the CATIA V5 environment 
CMI_RESTORE_POSITION=ON 

This function restores the positions to their original state loaded f rom Teamcenter.  
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Reset Invalid Positions  

An optional CATIA V5 menu item that allows to reset invalid Model-positions to the 

initial state (identity-matrix). 

CMI_ENABLE_RESETINVALIDPOSCMD=ON 

Get original geometry from Teamcenter 

 

To enable the Get original geometry from Teamcenter command the administrator 
has to set the CATIA V5 environment  
CMI_ENABLE_CMIGETORIGGEOCMD=ON 

 
A Part or V4 Model has to be selected in the product structure. The command retrieves 
the geometry f ile (CATPart or V4 model) f rom Teamcenter if  it is not yet loaded in CATIA 

V5. The function is used in context of  the Release Cache (Working with CATIA V5 
Released Cache), to get the original geometry f ile f rom Teamcenter if  only CGR’s are 
transferred by the conf iguration. 

Choose Update Position    

 

To get this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_UPDATEPOSITIONDIALOG=ON 
This function is available for normal “Update” and the “Update Position” 

 

 

Figure 148: Choose Matrix to Update 

If  you have changed some positions in the CATIA session this function allows you to 

select the relations to be updated.  
If  you select a line in the dialog the corresponding instance will be highlighted in the 
CATIA structure tree.  
Yes → Matrix will be updated in Teamcenter 

No   → Matrix will stay unchanged in Teamcenter 
To change the state you can double click a line or select the line and press the “Toggle 
keep state” button. 
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Version check during Read 

 

If  you read a f ile f rom Teamcenter, and another version of  the f ile is already open in 
CATIA, the new version of  the f ile cannot be opened, until you close the f ile in CATIA. 
However, CMI will set the metadata, so the open f ile can eg. be saved as the new 

version. 
 
You can enable a more strict control of  version mismatches. If  the variable  

 CMI_PREVENT_DIFFERENT_VERSIONS=ON 
is set in your CATIA environment, CMI will abort the Read if  there is a version ambiguity 
either in the Workbench product structure or between the Workbench product structure 

and the current contents of  the CATIA session. 
 

Check for Educational Flag 

CMI can make sure that no CATIA documents that were created with an educational 
license of  CATIA are entered into your PDM system. 

Set CMI_ENABLE_EDUFLAG_CHECK=ON to check for educational f lag during Update / 
Synchronize / Create / SaveAs. If  any f ile was created with an educational license, the 
Save action will be declined. 

Reference Geometries 

The concept of  reference geometries lets you include Parts and Assemblies in the CATIA 
product structure that are not part of  the general Teamcenter Assembly structure / Bill of  

Material (BOM). This allows to reference context geometry in the CATIA structure, eg. for 
drawing creation. 
 

 

Figure 149: Reference Geometry 

Reference geometry can be inserted below a CATIA component that adheres to a special, 
conf igurable naming convention. Synchronize will create a CMI specif ic relation between 

these Parts and the Teamcenter assembly structure. From then on, you can load these 

reference parts along with the regular assembly structure whenever required.  
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Figure 150: Expand with Reference 

 

Figure 151: Expanded Reference 

The reference geometry relation is a product element structure relation. Conf iguration 

context applies. 

In order to use this functionality, your administrator has to conf igure the pref ix for the 

Reference component in CATIA V5. See CMI Customizing Guide. 

Import / Export using a mapping file 

Set CMI_ENABLE_CREATE_IMPORT_FILE=ON to enable options in CMI Reconnect 
and Synchronize Teamcenter commands to map CATIA data that exists both in your PDM 

system and at a partner site, but under dif ferent naming conventions. 

Synchonize 

Use the Write Import/Export mapping file option in the Synchronize dialog to record or 
map original names for CATIA data that is stored in Teamcenter.  
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Figure 152: Synchronize - Write import/export mapping file 

 

Figure 153: Create CMI Mapping file 

As a result of  the Synchronize, an XML mapping f ile is created and attached to the Top 

level assembly in Teamcenter of  the new structure. This f ile maps original names to 
Teamcenter names and will be used by the Reconnect and Export commands.  
 

 

Figure 154: CMI Mapping file in Teamcenter 
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You should also check this option if  you receive a changed version of  a structure that was 

imported, to update the mapping f ile with new subassemblies.  

Reconnect 

If  a mapping f ile was created when the product structure was f irst imported into 

Teamcenter, this f ile can be used to map the CATIA names to the names the products 
have in Teamcenter. Click Use mapping file to retrieve a mapping f ile that is attached to 
the top level Part f rom Teamcenter. If  a part was imported f rom outside, the internal name 

will be supplied by the mapping f ile. 

  

Figure 155: CMI Reconnect 

Export to Folder Command 

Set CMI_ENABLE_EXPORTCMD=ON to enable the Export command in the CATIA 

toolbar. 

With the export command you can save data that you have opened f rom Teamcenter to a 
folder of  your choice. If  a mapping f ile is available the products in the structure can be 

renamed to their original part numbers and f ile names. 

This allows you to return f iles that you have originally received f rom an external partner, in 

their original state.  

 

Figure 156: Create CMI Mapping file 

CMI asks if  you want to use the mapping f ile: 

 

 

Figure 157: Use mapping file for export dialog 

If  “Yes” the structure is stored in the export directory using the original names of  the CMI 

Mapping f ile.  

If  “No” the structure is stored into the export directory without renaming.  
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CMI opens a folder selection dialog to select a directo ry where CMI should store the 

exported f iles:  

 

 

Figure 158: Select export directory dialog 

With “OK” CMI performs the export. 

Af ter the structure is stored in the export directory CMI shows a summary  about the 

renamed f iles. 

 

 

Figure 159: Export Information 

The export directory now holds the CATIA f iles of  the exported structure and an XML f ile 

which holds the actual mapping of  names between Teamcenter and the external structure. 
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The f iles in the CATIA session are now “external” and can no longer be updated with CMI. 

The CATProducts / CATParts point to the external f iles in the export directory. The part 
numbers are set to the original part numbers stored in the CMI Mapping f ile.  If  
CMI_EXPORT_STDATTRIBUTES was set the conf igured attributes Nomenclature, 

Def inition, Revision or Description are also set back to their original values.  

CGM File support 

In order to use CGM f iles with CATIA, set CMI_ENABLE_CGM=ON in the CATIA 
environment. CMI will support the Teamcenter OOTB class CGM:Computer Graphics 
Metafile f rom the Industry Standard Classes for basic Read and Update operations with 

CATIA V5. Please observe the following: 
A CGM is always updated in Update or Synchronize regardless of  modif ications made. 
A CGM in a product structure is by default not sent to Catia or expanded in the 

Workbench. To expand and send it, go to Options → Model Filter in the Workbench and 
check Use model filter. In order to view CGM f iles, the Model Type CATIA V5 
Visualization must be selected. 

 

 

Figure 160: Model Filter Preferences 

Deleting NON-BOM Parts during Synchronize 

By default, when you remove an instance of  a geometry (Non-BOM CATPart) in CATIA, 
Synchronize Teamcenter does not perform any action in Teamcenter. This is because 

there is no clearly equivalent action in Teamcenter that CMI can provide – for instance, it 
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cannot tell if  you would remove the document f rom the Part or the CATPart  f rom its 

Document. 
 
If  a user would regularly remove the Document f rom its Part, an administrator can set the 

following variable in the Teamcenter conf iguration: 
 
set CMI_REMOVE_GEOMETRY “DOCUMENT”; 

 
this would remove all versions of  the document f rom the Part that attach the CATPart 
which was removed in CATIA. This is appropriate if  your business logic is that each 

CATPart has its own document (the document attaches only one model) 
 
If  you would remove the Model f rom its document an administrator can set the following 

variable in the Teamcenter conf iguration: 
 
set CMI_REMOVE_GEOMETRY “MODEL”; 

 
This method is suitable if  your Document attaches more than one model, and no 
Document is attached to more than one Part. 

 
If  none of  these def initions match your business logic, you should instead override the 
customizing method for the dropping of  geometries (see CMI Customizing Manual) or let 

the user handle it. 
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Glossary 

Administrator 

Person, who conf igures the system, inserts users, manages users permissions and 

maintains the database.  

Browser 

Window that displays icons representing objects. 

CATEDM 

CATIA Engineering Data Management System Integration. The CATIA add on (GII 
module) which enables several PDM systems to communicate with the CATIA system in 

terms of  managing CATIA models and structures. The name of  the module can dif fer f rom 

installation to installation (i.e. METAPHSE). 

Check In 

Action that takes f rom the users the right to update a work item.  

Check Out 

Action that gives the user the exclusive right to update a work item. Checking out an item 

creates a copy of  the work item in the specif ied work location.  

Configuration Context 

An attribute that determines which Part versions should be displayed (for example, only 

the last revisions). 

Dialog Window 

Window in which the user enters information. 

Field 

Component of  a dialog window in which the user can enter text. 

Generic Workbench 

Set of  components such as windows, dynamic items and information items, used in 

Teamcenter integration products. 

GII 

Graphics Interactive Interface. The GII is a powerful programming tool, which completes 

the Open System Access to the CATIA environment.  

Icon 

Graphical representation of  an object. 
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List View 

Style of  browser window in which objects are viewed as small icons in a list with attribute 

values in columns.  

Object 

An item or relationship. 

Object Management Framework (OMF) 

Teamcenter module where it is possible to f ind the tools and the information needed to the 

common users activities. Within OMF, each piece of  information is an object represented 

by an icon that users can manipulate. 

Palette 

Any group of  CATIA functions created for specif ic requirements.  

Plot File  

File in a specif ied format that can be plotted or opened in a viewing tool and represents a 

2D view of  a model. 

Pop-Up Menu 

The menu that appears when the user points an icon and holds the right mouse button 

pressed. 

Query  

To search the database for objects that match specif ic criteria. 

Register 

To make a f ile or directory known as an object maintained in the Teamcenter database. 

Tree View 

Style of  browser window in which objects are displayed as relationships in horizontal 

branches. 

Vault 

Secure place for storing information. To access the data conf ined in a vault it is necessary 

to check out or revise the data. 


